@sigstore/core has DSSE payloadType type-binding failure
CVE-2026-48758GHSA-jfc7-64v2-mr8c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sigstore/core 3.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @sigstore/core
- Affected
- <= 3.2.0
- Fixed in
- 3.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jfc7-64v2-mr8c lists affected ranges: npm @sigstore/core >=0 <3.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfc7-64v2-mr8c lists affected ranges: npm @sigstore/core >=0 <=3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-48758: 0.24% estimated exploitation activity in the next 30 days; percentile 15.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The preAuthEncoding function in @sigstore/core uses Node.js 'ascii' encoding when converting the PAE (Pre-Authentication Encoding) string to bytes. This allows payloadType to be mutated after signing without invalidating the signature, breaking the type-binding guarantee that DSSE is designed to provide. In packages/core/src/dsse.ts, the PAE function builds a string containing payloadType and then encodes it with Buffer.from(prefix, 'ascii'). In Node.js, 'ascii' encoding for string-to-Buffer is equivalent to 'latin1', which truncates characters above U+00FF to their low byte. This means for any ASCII character, there exist Unicode characters (at U+01xx, U+02xx, etc.) that produce the identical encoded byte: | Original | Codepoint | Mutant | Codepoint | Encoded byte | |----------|-----------|--------|-----------|--------------| | t | U+0074 | Ŵ | U+0174 | 0x74 | | e | U+0065 | ť | U+0165 | 0x65 | An attacker can substitute every character in payloadType with a Unicode variant…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jfc7-64v2-mr8c
- Revision 1 · created ·
Published from osv record GHSA-jfc7-64v2-mr8c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48758 Advisory: @sigstore/core has DSSE payloadType type-binding failure IDs: CVE-2026-48758, GHSA-jfc7-64v2-mr8c Record: https://patchnext.com/advisories/cve-2026-48758 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sigstore/core 3.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sigstore/core: affected <= 3.2.0; fixed in 3.2.1 ## Suggested inspection (read-only) - `npm ls @sigstore/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sigstore/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jfc7-64v2-mr8c (OSV record GHSA-jfc7-64v2-mr8c lists affected ranges: npm @sigstore/core >=0 <3.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-jfc7-64v2-mr8c (GitHub-reviewed advisory GHSA-jfc7-64v2-mr8c lists affected ranges: npm @sigstore/core >=0 <=3.2.0) Commands are suggestions: review each one before running it.
Loading voting…