Skip to content

← Actionable
Critical, CVSS 9.1amended

vLLM: OpenAI auth bypass

CVE-2026-48746GHSA-94f4-hr76-p5j6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.3.0, < 0.22.0
    Fixed in
    0.22.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
  • CVE-2026-48746: 1.15% estimated exploitation activity in the next 30 days; percentile 66.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability in ASGI web servers and starlette's trust on those web servers enables an authentication bypass of the OpenAI API AuthenticationMiddleware, which was discovered during @x41sec's source code audit. It allows to use the API without providing the configured VLLMAPIKEY or --api-key. Details In https://github.com/vllm-project/vllm/blob/v0.14.0/vllm/entrypoints/openai/apiserver.py#L689-L692 the urlpath is taken from the URL, which is reconstructed by starlette based on the request scope. The request scope includes the request's Host: header and reconstructs the URL as shown below: Neither starlette nor any of the ASGI servers (including uvicorn, which vllm uses) properly filter the Host: header for invalid characters. This allows an attacker to include special URL characters such as / or ? in the Host: header and thereby control the reconstructed URL and it's .path attribute. FastAPI/starlette's routing uses the HTTP path and does not depend on the parsed url.path…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-94f4-hr76-p5j6

  2. Revision 2 · amended ·

    Amended from osv record GHSA-94f4-hr76-p5j6

  3. Revision 1 · created ·

    Published from ghsa record GHSA-94f4-hr76-p5j6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48746

Advisory: vLLM: OpenAI auth bypass
IDs: CVE-2026-48746, GHSA-94f4-hr76-p5j6
Record: https://patchnext.com/advisories/cve-2026-48746 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.3.0, < 0.22.0; fixed in 0.22.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-94f4-hr76-p5j6 (GitHub-reviewed advisory GHSA-94f4-hr76-p5j6 lists affected ranges: PyPI vllm >=0.3.0 <0.22.0)
- Verified: https://osv.dev/vulnerability/GHSA-94f4-hr76-p5j6 (OSV record GHSA-94f4-hr76-p5j6 lists affected ranges: PyPI vllm >=0.3.0 <0.22.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…