Symfony: IpUtils::PRIVATE_SUBNETS Omits IPv6 Transition Forms (6to4, NAT64, Teredo, IPv4-compatible): SSRF Bypass in NoPrivateNetworkHttpClient
CVE-2026-48736GHSA-38cx-cq6f-5755
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.0.13, 7.4.13, 6.4.41, 5.4.53; symfony/http-client 5.4.53; symfony/http-foundation 8.0.13, 7.4.13, 6.4.41), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 5.4.0, < 5.4.53>= 6.4.0, < 6.4.41>= 7.0.0, < 7.4.13>= 8.0.0, < 8.0.13
- Fixed in
- 6.4.41, 8.0.13, 7.4.13, 5.4.53
Packagist symfony/http-client
- Affected
- >= 5.4.0, < 5.4.53
- Fixed in
- 5.4.53
Packagist symfony/http-foundation
- Affected
- >= 6.4.0, < 6.4.41>= 7.0.0, < 7.4.13>= 8.0.0, < 8.0.13
- Fixed in
- 6.4.41, 8.0.13, 7.4.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-38cx-cq6f-5755 lists affected ranges: Packagist symfony/http-client >=5.4.0 =6.4.0 =7.0.0 =8.0.0 =5.4.0 =6.4.0 =7.0.0 =8.0.0 <8.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-48736: 0.57% estimated exploitation activity in the next 30 days; percentile 47.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Symfony\Component\HttpClient\NoPrivateNetworkHttpClient is documented as a decorator that blocks requests to private networks by default. The list of blocked subnets (Symfony\Component\HttpFoundation\IpUtils::PRIVATESUBNETS on 6.4+, a private constant in NoPrivateNetworkHttpClient on 5.4) enumerates RFC1918, loopback, link-local and IPv4-mapped IPv6 (::ffff:0:0/96) prefixes, but omits the remaining IPv6 transition forms that can embed a private IPv4 destination: 6to4 (2002::/16, RFC 3056), Teredo (2001::/32, RFC 4380), NAT64 (64:ff9b::/96, RFC 6052 and 64:ff9b:1::/48, RFC 8215) and IPv4-compatible IPv6 (::/96, RFC 4291 §2.5.5.1). IpUtils::checkIp6() is a pure bitwise CIDR comparison against the constants list and never extracts the embedded IPv4, so an attacker who can supply a URL writes the loopback / RFC1918 IPv4 target as e.g. http://[2002:7f00:1::]/ (6to4 → 127.0.0.1), http://[64:ff9b::7f00:1]/ (NAT64 → 127.0.0.1), http://[::7f00:1]/ (IPv4-compatible → 127.0.0.1) or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-38cx-cq6f-5755
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48736 Advisory: Symfony: IpUtils::PRIVATE_SUBNETS Omits IPv6 Transition Forms (6to4, NAT64, Teredo, IPv4-compatible): SSRF Bypass in NoPrivateNetworkHttpClient IDs: CVE-2026-48736, GHSA-38cx-cq6f-5755 Record: https://patchnext.com/advisories/cve-2026-48736 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.0.13, 7.4.13, 6.4.41, 5.4.53; symfony/http-client 5.4.53; symfony/http-foundation 8.0.13, 7.4.13, 6.4.41. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 5.4.0, < 5.4.53; >= 6.4.0, < 6.4.41; >= 7.0.0, < 7.4.13; >= 8.0.0, < 8.0.13; fixed in 6.4.41, 8.0.13, 7.4.13, 5.4.53 - Packagist symfony/http-client: affected >= 5.4.0, < 5.4.53; fixed in 5.4.53 - Packagist symfony/http-foundation: affected >= 6.4.0, < 6.4.41; >= 7.0.0, < 7.4.13; >= 8.0.0, < 8.0.13; fixed in 6.4.41, 8.0.13, 7.4.13 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/http-client: check the installed version with your package manager. - Packagist symfony/http-foundation: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/http-client, symfony/http-foundation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-38cx-cq6f-5755 (GitHub-reviewed advisory GHSA-38cx-cq6f-5755 lists affected ranges: Packagist symfony/http-client >=5.4.0 =6.4.0 =7.0.0 =8.0.0 =5.4.0 =6.4.0 =7.0.0 =8.0.0 <8.0.13) Commands are suggestions: review each one before running it.
Loading voting…