nextflow auth login command has incorrect default permissions
CVE-2026-48722GHSA-92qf-fcph-v5wr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.nextflow:nextflow 26.04.3, 25.10.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.nextflow:nextflow
- Affected
- >= 25.09.2-edge, < 25.10.6>= 26.00.0-edge, < 26.04.3
- Fixed in
- 26.04.3, 25.10.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-92qf-fcph-v5wr lists affected ranges: Maven io.nextflow:nextflow >=25.09.2-edge =26.00.0-edge <26.04.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-48722: 0.14% estimated exploitation activity in the next 30 days; percentile 3.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact nextflow auth login persists Seqera Platform OIDC tokens to ${NXFHOME:-~/.nextflow}/seqera-auth.config. The file is created via Java NIO without specifying file permissions, so under the default umask 022 it lands at mode 0644 (world-readable). On a multi-user POSIX host — typically an HPC login node, shared workstation, or jump host — any local user able to traverse the victim's home directory can read the file and obtain a valid Platform bearer token, enabling impersonation against Seqera Platform within the token's scope. Single-user systems and headless CI runners, which do not invoke the interactive login flow, are not affected. Affected versions: 25.09.2-edge through 26.04.1. Patches Fixed in <PATCHEDVERSION. The patched code applies mode 0600 to seqera-auth.config immediately after writing it, and re-applies on every subsequent login so any pre-existing world-readable copy left by an earlier version is tightened. Tokens previously stored in the file must be treated as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-92qf-fcph-v5wr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48722 Advisory: nextflow auth login command has incorrect default permissions IDs: CVE-2026-48722, GHSA-92qf-fcph-v5wr Record: https://patchnext.com/advisories/cve-2026-48722 (revision 1, source checked 26 Oct 2026, 16:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.nextflow:nextflow 26.04.3, 25.10.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.nextflow:nextflow: affected >= 25.09.2-edge, < 25.10.6; >= 26.00.0-edge, < 26.04.3; fixed in 26.04.3, 25.10.6 ## Suggested inspection (read-only) - Maven io.nextflow:nextflow: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.nextflow:nextflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-92qf-fcph-v5wr (GitHub-reviewed advisory GHSA-92qf-fcph-v5wr lists affected ranges: Maven io.nextflow:nextflow >=25.09.2-edge =26.00.0-edge <26.04.3) Commands are suggestions: review each one before running it.
Loading voting…