i18next-http-middleware: MissingKeyHandler does not reject keys whose segments contain prototype-polluting names
CVE-2026-48714GHSA-f49m-vf83-692w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next-http-middleware 3.9.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.9.7
- Fixed in
- 3.9.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f49m-vf83-692w lists affected ranges: npm i18next-http-middleware >=0 <3.9.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f49m-vf83-692w lists affected ranges: npm i18next-http-middleware >=0 <3.9.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2026-48714: 0.49% estimated exploitation activity in the next 30 days; percentile 42.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact i18next-http-middleware ≤ 3.9.6's missingKeyHandler blocked the literal request-body keys proto, constructor, and prototype (added in 3.9.3, see GHSA-5fgg-jcpf-8jjw), but did not reject dotted variants such as "proto.polluted". Downstream backends that split the missing-key string on a configured keySeparator (notably i18next-fs-backend ≤ 2.6.5) hand these keys to an unguarded setPath() walker that writes to Object.prototype. Applications that expose missingKeyHandler to untrusted input AND use i18next-fs-backend ≤ 2.6.5 are directly exploitable for remote prototype pollution. Other downstream backends that split the missing-key string the same way may be similarly affected. Depending on the host application, polluted prototype properties may cause crashes, corrupted translation behaviour, configuration poisoning, or bypasses of property-based security checks. Patches Fixed in i18next-http-middleware 3.9.7. A new utils.hasUnsafeKeySegment(key, keySeparator) helper is now used…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f49m-vf83-692w
- Revision 2 · amended ·
Amended from osv record GHSA-f49m-vf83-692w
- Revision 1 · created ·
Published from ghsa record GHSA-f49m-vf83-692w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48714 Advisory: i18next-http-middleware: MissingKeyHandler does not reject keys whose segments contain prototype-polluting names IDs: CVE-2026-48714, GHSA-f49m-vf83-692w Record: https://patchnext.com/advisories/cve-2026-48714 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: i18next-http-middleware 3.9.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm i18next-http-middleware: affected < 3.9.7; fixed in 3.9.7 ## Suggested inspection (read-only) - `npm ls i18next-http-middleware --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on i18next-http-middleware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f49m-vf83-692w (GitHub-reviewed advisory GHSA-f49m-vf83-692w lists affected ranges: npm i18next-http-middleware >=0 <3.9.7) - Verified: https://osv.dev/vulnerability/GHSA-f49m-vf83-692w (OSV record GHSA-f49m-vf83-692w lists affected ranges: npm i18next-http-middleware >=0 <3.9.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…