Skip to content

← Actionable
Critical, CVSS 9.1amended

i18next-fs-backend vulnerable to prototype pollution via crafted missing-key string

CVE-2026-48713GHSA-2933-q333-qg83

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next-fs-backend 2.6.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-48713: 0.49% estimated exploitation activity in the next 30 days; percentile 42.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact i18next-fs-backend ≤ 2.6.5, when used to persist missing translation keys (e.g. via i18next-http-middleware's missingKeyHandler exposed to untrusted input), is vulnerable to prototype pollution via crafted missing-key strings. Backend.writeFile() splits each queued missing-key string on the configured keySeparator (default .) before calling the internal setPath() walker. The walker (getLastOfPath in lib/utils.js) did not guard against unsafe segments, so a key like "proto.polluted" was split into ["proto", "polluted"] and walked straight into Object.prototype, allowing an attacker to write arbitrary properties onto the global object prototype. Depending on the host application, polluted prototype properties may cause crashes, corrupted translation behaviour, configuration poisoning, or bypasses of property-based security checks. Affected configuration Applications are directly affected only if all of the following hold: - i18next-fs-backend ≤ 2.6.5 is configured as the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2933-q333-qg83

  2. Revision 2 · amended ·

    Amended from osv record GHSA-2933-q333-qg83

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2933-q333-qg83

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48713

Advisory: i18next-fs-backend vulnerable to prototype pollution via crafted missing-key string
IDs: CVE-2026-48713, GHSA-2933-q333-qg83
Record: https://patchnext.com/advisories/cve-2026-48713 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: i18next-fs-backend 2.6.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm i18next-fs-backend: affected < 2.6.6; fixed in 2.6.6

## Suggested inspection (read-only)
- `npm ls i18next-fs-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on i18next-fs-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2933-q333-qg83 (GitHub-reviewed advisory GHSA-2933-q333-qg83 lists affected ranges: npm i18next-fs-backend >=0 <2.6.6)
- Verified: https://osv.dev/vulnerability/GHSA-2933-q333-qg83 (OSV record GHSA-2933-q333-qg83 lists affected ranges: npm i18next-fs-backend >=0 <2.6.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…