MONAILabel Server Crash and Silent Inference Corruption via Crafted DICOM (pydicom DS/IS Validation Bypass)
CVE-2026-48705GHSA-6hp3-vr39-rqw8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (monai 1.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI monai
- Affected
- < 1.6.1
- Fixed in
- 1.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6hp3-vr39-rqw8 lists affected ranges: PyPI monai >=0 <1.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6hp3-vr39-rqw8 lists affected ranges: PyPI monai >=0 <1.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary An unauthenticated remote attacker can crash a running MONAILabel server or silently corrupt its medical AI inference results by uploading a single crafted DICOM file (~132 KB) via the REST API. The vulnerability stems from pydicom's lack of validation for Decimal String (DS) and Integer String (IS) DICOM Value Representations, which allows NaN and infinity values to pass through MONAI's PydicomReader and propagate through the entire spatial transform and ML inference pipeline. No authentication is required for the default MONAILabel REST API. The attacker needs only network access to the server (default port 8000). Severity: CVSS 3.1: 8.7 HIGH CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:L CWE: CWE-20 (Improper Input Validation) → CWE-682 (Incorrect Calculation)
Details Root Cause — Layer 1: pydicom accepts invalid VR values pydicom's `DSfloat.new()` calls Python's `float(val)`, which silently accepts "NaN", "inf", and "-inf". The DICOM…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-6hp3-vr39-rqw8
- Revision 1 · created ·
Published from ghsa record GHSA-6hp3-vr39-rqw8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48705 Advisory: MONAILabel Server Crash and Silent Inference Corruption via Crafted DICOM (pydicom DS/IS Validation Bypass) IDs: CVE-2026-48705, GHSA-6hp3-vr39-rqw8 Record: https://patchnext.com/advisories/cve-2026-48705 (revision 2, source checked 28 Oct 2026, 06:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: monai 1.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI monai: affected < 1.6.1; fixed in 1.6.1 ## Suggested inspection (read-only) - `python -m pip show monai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on monai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6hp3-vr39-rqw8 (OSV record GHSA-6hp3-vr39-rqw8 lists affected ranges: PyPI monai >=0 <1.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-6hp3-vr39-rqw8 (GitHub-reviewed advisory GHSA-6hp3-vr39-rqw8 lists affected ranges: PyPI monai >=0 <1.6.1) Commands are suggestions: review each one before running it.
Loading voting…