Unbounded memory growth in node:http2 clients via attacker-controlled ORIGIN frames
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 26.3.1, 24.17.0, 22.23.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 22.0.0, < 22.23.0>= 24.0.0, < 24.17.0>= 26.0.0, < 26.3.1
- Fixed in
- 22.23.0, 26.3.1, 24.17.0
Sources
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2026-48619 to 2026-06-17.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 175 lists CVE-2026-48619 affecting node >=22.0.0 =24.0.0 =26.0.0 <26.3.1
VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-48619: 0.64% estimated exploitation activity in the next 30 days; percentile 50.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw in Node.js HTTP/2 client allows a server to send an unlimited number of ORIGIN frames, which could lead to an Out of Memory error on the client. This vulnerability affects all supported release lines: Node.js 22, Node.js 24, and Node.js 26.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · published ·
Published from vendor_advisory record nodejs-security-wg:core:175
- Revision 1 · created ·
Created from vendor_advisory record nodejs-security-wg:core:175
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48619 Advisory: Unbounded memory growth in `node:http2` clients via attacker-controlled ORIGIN frames IDs: CVE-2026-48619 Record: https://patchnext.com/advisories/cve-2026-48619 (revision 2, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 26.3.1, 24.17.0, 22.23.0. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 22.0.0, < 22.23.0; >= 24.0.0, < 24.17.0; >= 26.0.0, < 26.3.1; fixed in 22.23.0, 26.3.1, 24.17.0 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2026-48619 to 2026-06-17.) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/175.json (Node.js security working group core entry 175 lists CVE-2026-48619 affecting node >=22.0.0 =24.0.0 =26.0.0 <26.3.1) Commands are suggestions: review each one before running it.
Loading voting…