Skip to content

← Actionable
High, CVSS 8.7amended

HaxCMS has a stored Cross-Site Scripting (XSS) bypass in its saveNode endpoint

CVE-2026-48527GHSA-g2g8-95qg-v35h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/haxcms-nodejs 26.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-48527: 0.23% estimated exploitation activity in the next 30 days; percentile 13.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary HaxCMS is affected by a stored cross-site scripting (XSS) vulnerability in the /system/api/saveNode endpoint. An authenticated user with a permission to edit pages can bypass the HTML sanitizer by injecting an event handler attribute without whitespace before the attribute name. For example, the sanitizer misses: The important bypass is: The payload is stored in the generated page files and executes when a user clicks the injected link. Details The issue is caused by regex-based HTML sanitization that expects whitespace before event handler attributes. Because the sanitizer expects a pattern like: It fails to remove an event handler when it is written without whitespace: Browsers still parse onclick as a valid event handler attribute, so the JavaScript executes when the element is clicked. Affected endpoint: Affected parameter: PoC 1. Log in to HaxCMS and edit any existing page. 2. Capture the page save request in Burp Suite: 3. In the JSON request body, modify only the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g2g8-95qg-v35h

  2. Revision 1 · created ·

    Published from osv record GHSA-g2g8-95qg-v35h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48527

Advisory: HaxCMS has a stored Cross-Site Scripting (XSS) bypass in its saveNode endpoint
IDs: CVE-2026-48527, GHSA-g2g8-95qg-v35h
Record: https://patchnext.com/advisories/cve-2026-48527 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/haxcms-nodejs 26.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @haxtheweb/haxcms-nodejs: affected <= 26.0.0; fixed in 26.0.1

## Suggested inspection (read-only)
- `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @haxtheweb/haxcms-nodejs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g2g8-95qg-v35h (OSV record GHSA-g2g8-95qg-v35h lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <26.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-g2g8-95qg-v35h (GitHub-reviewed advisory GHSA-g2g8-95qg-v35h lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 <=26.0.0)

Commands are suggestions: review each one before running it.

Loading voting…