Skip to content

← Actionable
Low, CVSS 3.7amended

PyJWKClient unbounded JWKS endpoint requests via attacker-controlled kid values (DoS)

CVE-2026-48524GHSA-fhv5-28vv-h8m8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyjwt 2.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyjwt

    Affected
    >= 2.0.0, <= 2.12.1
    Fixed in
    2.13.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-48524: 0.40% estimated exploitation activity in the next 30 days; percentile 34.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

[!NOTE] The vulnerability surfaces only when a JWKS fetch fails; an attacker can attempt to provoke that with sustained unknown-kid traffic, but the outcome depends on upstream JWKS-endpoint behavior (rate limiting, transient errors) which is beyond the attacker's control. Impact is reduced auth availability until the next successful fetch, not complete denial of service. Summary PyJWKClient.getsigningkey() forces a fresh HTTP request to the JWKS endpoint for every JWT with an unknown kid value, with no rate limiting. Since kid comes from the unverified token header, an attacker can trigger unlimited outbound requests. Additionally, fetchdata() finally block clears the JWKS cache on network error. Root Cause jwt/jwksclient.py:172-198 - getsigningkey(kid) calls getsigningkeys(refresh=True) for unknown kids, bypassing TTL cache with no cooldown. jwt/jwksclient.py:120-122 - finally block writes None to cache on error, clearing valid data. Impact - DoS against JWKS endpoint (unlimited…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fhv5-28vv-h8m8

  2. Revision 1 · created ·

    Published from osv record GHSA-fhv5-28vv-h8m8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48524

Advisory: PyJWKClient unbounded JWKS endpoint requests via attacker-controlled kid values (DoS)
IDs: CVE-2026-48524, GHSA-fhv5-28vv-h8m8
Record: https://patchnext.com/advisories/cve-2026-48524 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyjwt 2.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyjwt: affected >= 2.0.0, <= 2.12.1; fixed in 2.13.0

## Suggested inspection (read-only)
- `python -m pip show pyjwt`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyjwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fhv5-28vv-h8m8 (OSV record GHSA-fhv5-28vv-h8m8 lists affected ranges: PyPI pyjwt >=2.0.0 <2.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fhv5-28vv-h8m8 (GitHub-reviewed advisory GHSA-fhv5-28vv-h8m8 lists affected ranges: PyPI pyjwt >=2.0.0 <=2.12.1)

Commands are suggestions: review each one before running it.

Loading voting…