Skip to content

← Actionable
Medium, CVSS 6.3

MessagePack-CSharp: JSON conversion APIs can recurse without consistent depth enforcement

CVE-2026-48512GHSA-cj9g-3mj2-g8vv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (messagepack 3.1.7, 2.5.301), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet messagepack

    Affected
    < 2.5.301>= 3.0, < 3.1.7
    Fixed in
    2.5.301, 3.1.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-48512: 0.40% estimated exploitation activity in the next 30 days; percentile 34.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary MessagePack-CSharp's JSON conversion helpers contain multiple recursion paths that do not consistently enforce a depth limit. These paths are in the JSON conversion component rather than normal typed MessagePack deserialization. Three related issues are covered by this advisory: 1. MessagePackSerializer.ConvertFromJson recursively processes nested JSON arrays and objects in FromJsonCore() without consulting MessagePackSecurity.MaximumObjectGraphDepth. 2. TinyJsonReader.ReadNextToken() recursively consumes comma and colon separator characters, allowing even malformed JSON with long separator runs to consume one stack frame per character. 3. MessagePackSerializer.ConvertToJson applies depth checks to arrays and maps, but the typeless extension branch for ext-100 recursively calls ToJsonCore() without applying MessagePackSecurity.DepthStep(ref reader). Each path can allow attacker-controlled input to exhaust the process stack and trigger an uncatchable StackOverflowException…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cj9g-3mj2-g8vv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48512

Advisory: MessagePack-CSharp: JSON conversion APIs can recurse without consistent depth enforcement
IDs: CVE-2026-48512, GHSA-cj9g-3mj2-g8vv
Record: https://patchnext.com/advisories/cve-2026-48512 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: messagepack 3.1.7, 2.5.301. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet messagepack: affected < 2.5.301; >= 3.0, < 3.1.7; fixed in 2.5.301, 3.1.7

## Suggested inspection (read-only)
- NuGet messagepack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on messagepack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cj9g-3mj2-g8vv (GitHub-reviewed advisory GHSA-cj9g-3mj2-g8vv lists affected ranges: NuGet messagepack >=0 =3.0 <3.1.7)

Commands are suggestions: review each one before running it.

Loading voting…