Lemur has an authorization bypass in StrictRolePermission / AuthorityCreatorPermission
CVE-2026-48508GHSA-qcqw-jwxc-2hqg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lemur 1.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lemur
- Affected
- <= 1.9.0
- Fixed in
- 1.9.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qcqw-jwxc-2hqg lists affected ranges: PyPI lemur >=0 <1.9.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qcqw-jwxc-2hqg lists affected ranges: PyPI lemur >=0 <=1.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-48508: 0.33% estimated exploitation activity in the next 30 days; percentile 26.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary StrictRolePermission and AuthorityCreatorPermission in lemur/auth/permissions.py call flaskprincipal.Permission.init() with zero Needs when their config flags are unset. Both flags defaulted to False in code prior to the fix, so this was the state of any Lemur install that hadn't explicitly opted in. Flask-Principal's Permission.allows() returns True whenever self.needs is empty. The .can() gate therefore passes for every authenticated identity, including the lowest-privilege role Lemur ships (read-only). A user holding only read-only can create root Certificate Authorities, create and edit notifications (an SSRF sink), create domain entries, and upload arbitrary certificates. These classes are the sole authorization check on those endpoints. Root Cause flaskprincipal.Permission.allows() (upstream, v0.4.0): When self.needs == set(), the first guard is falsy and is skipped. excludes is also empty, so allows() returns True for any identity. AuthenticatedResource (the parent…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qcqw-jwxc-2hqg
- Revision 1 · created ·
Published from osv record GHSA-qcqw-jwxc-2hqg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48508 Advisory: Lemur has an authorization bypass in StrictRolePermission / AuthorityCreatorPermission IDs: CVE-2026-48508, GHSA-qcqw-jwxc-2hqg Record: https://patchnext.com/advisories/cve-2026-48508 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lemur 1.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lemur: affected <= 1.9.0; fixed in 1.9.1 ## Suggested inspection (read-only) - `python -m pip show lemur`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lemur. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qcqw-jwxc-2hqg (OSV record GHSA-qcqw-jwxc-2hqg lists affected ranges: PyPI lemur >=0 <1.9.1 (fixed)) - Verified: https://github.com/advisories/GHSA-qcqw-jwxc-2hqg (GitHub-reviewed advisory GHSA-qcqw-jwxc-2hqg lists affected ranges: PyPI lemur >=0 <=1.9.0) Commands are suggestions: review each one before running it.
Loading voting…