Filament: Multi-factor authentication (app) recovery codes can still be used multiple times via concurrent submission
CVE-2026-48505GHSA-mc5j-f6wx-h9qh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (filament/filament 5.6.5, 4.11.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist filament/filament
- Affected
- >= 4.0.0, < 4.11.5>= 5.0.0, < 5.6.5
- Fixed in
- 4.11.5, 5.6.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mc5j-f6wx-h9qh lists affected ranges: Packagist filament/filament >=4.0.0 =5.0.0 <5.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-48505: 0.30% estimated exploitation activity in the next 30 days; percentile 22.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw in the handling of recovery codes for app-based multi-factor authentication allows the same recovery code to be reused via concurrent submission. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled. If an attacker gains access to both the user's password and their recovery codes, they get two authenticated sessions per recovery code burned instead of one, or more if they batch the parallel submissions wider, materially extending the attacker's window of access compared to what the single-use guarantee implies.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mc5j-f6wx-h9qh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48505 Advisory: Filament: Multi-factor authentication (app) recovery codes can still be used multiple times via concurrent submission IDs: CVE-2026-48505, GHSA-mc5j-f6wx-h9qh Record: https://patchnext.com/advisories/cve-2026-48505 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: filament/filament 5.6.5, 4.11.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist filament/filament: affected >= 4.0.0, < 4.11.5; >= 5.0.0, < 5.6.5; fixed in 4.11.5, 5.6.5 ## Suggested inspection (read-only) - Packagist filament/filament: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on filament/filament. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mc5j-f6wx-h9qh (GitHub-reviewed advisory GHSA-mc5j-f6wx-h9qh lists affected ranges: Packagist filament/filament >=4.0.0 =5.0.0 <5.6.5) Commands are suggestions: review each one before running it.
Loading voting…