Filament: Unauthenticated temporary file upload on auth pages
CVE-2026-48500GHSA-44wp-g8f4-f4v5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (filament/filament 5.6.5, 4.11.5, 3.3.52), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist filament/filament
- Affected
- >= 4.0.0, <= 4.11.4>= 5.0.0, <= 5.6.4>= 3.0.0, <= 3.3.51
- Fixed in
- 4.11.5, 3.3.52, 5.6.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-44wp-g8f4-f4v5 lists affected ranges: Packagist filament/filament >=4.0.0 =5.0.0 =3.0.0 <=3.3.51
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-48500: 0.34% estimated exploitation activity in the next 30 days; percentile 27.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Any schema can contain a file upload form field, so Filament applies Livewire's WithFileUploads trait to the Livewire component the schema is embedded in. However, some schemas, such as the panel login form, do not require file uploads, and exposing unauthenticated temporary file uploads on these components is not an acceptable risk. On these components, an unauthenticated attacker could upload arbitrary files to the application's temporary storage, which could be abused to exhaust disk space or inflate storage costs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-44wp-g8f4-f4v5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48500 Advisory: Filament: Unauthenticated temporary file upload on auth pages IDs: CVE-2026-48500, GHSA-44wp-g8f4-f4v5 Record: https://patchnext.com/advisories/cve-2026-48500 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: filament/filament 5.6.5, 4.11.5, 3.3.52. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist filament/filament: affected >= 4.0.0, <= 4.11.4; >= 5.0.0, <= 5.6.4; >= 3.0.0, <= 3.3.51; fixed in 4.11.5, 3.3.52, 5.6.5 ## Suggested inspection (read-only) - Packagist filament/filament: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on filament/filament. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-44wp-g8f4-f4v5 (GitHub-reviewed advisory GHSA-44wp-g8f4-f4v5 lists affected ranges: Packagist filament/filament >=4.0.0 =5.0.0 =3.0.0 <=3.3.51) Commands are suggestions: review each one before running it.
Loading voting…