Skip to content

← Actionable
Medium, CVSS 4.9

Snipe-IT's selectlist visibility is too permissive

CVE-2026-48492GHSA-f3c5-6cw8-fg57

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 8.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-48492: 0.39% estimated exploitation activity in the next 30 days; percentile 32.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The GET /api/v1/{object}/selectlist API endpoint is missing an authorization check. Any user who can log into Snipe-IT - regardless of permissions - can retrieve a paginated list of all user accounts using only their web session cookie. No API token or elevated permissions are required. This exposes usernames, display names, employee numbers, and user IDs for every active account in the system if FMCS is not enabled, and within the company they belong to if FMCS is enabled. What an attacker can do with a valid login and zero permissions: - Enumerate all active user accounts by paginating through the endpoint - Harvest usernames for credential stuffing or password spray attacks - Collect employee numbers and full names for social engineering - Perform indirect email enumeration via the search parameter - Map user IDs for use in further enumeration against other endpoints This vulnerability is exploitable only by users who have a working login to the Snipe-IT system. Patches…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f3c5-6cw8-fg57

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48492

Advisory: Snipe-IT's selectlist visibility is too permissive
IDs: CVE-2026-48492, GHSA-f3c5-6cw8-fg57
Record: https://patchnext.com/advisories/cve-2026-48492 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 8.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist snipe/snipe-it: affected < 8.5.1; fixed in 8.5.1

## Suggested inspection (read-only)
- Packagist snipe/snipe-it: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on snipe/snipe-it.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f3c5-6cw8-fg57 (GitHub-reviewed advisory GHSA-f3c5-6cw8-fg57 lists affected ranges: Packagist snipe/snipe-it >=0 <8.5.1)

Commands are suggestions: review each one before running it.

Loading voting…