Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes
CVE-2026-48489GHSA-6h46-9jf5-q59x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 8.0.13, 7.4.13, 6.4.41, 5.4.53; symfony/security-http 8.0.13, 7.4.13, 6.4.41, 5.4.53), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- < 5.4.53>= 6.0.0, < 6.4.41>= 7.0.0, < 7.4.13>= 8.0.0, < 8.0.13
- Fixed in
- 6.4.41, 8.0.13, 7.4.13, 5.4.53
Packagist symfony/security-http
- Affected
- < 5.4.53>= 6.0.0, < 6.4.41>= 7.0.0, < 7.4.13>= 8.0.0, < 8.0.13
- Fixed in
- 6.4.41, 8.0.13, 7.4.13, 5.4.53
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6h46-9jf5-q59x lists affected ranges: Packagist symfony/security-http >=0 =6.0.0 =7.0.0 =8.0.0 =0 =6.0.0 =7.0.0 =8.0.0 <8.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-48489: 0.60% estimated exploitation activity in the next 30 days; percentile 48.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description When a firewall is configured with form-login (or any authenticator using DefaultAuthenticationFailureHandler) and the failureforward: true option, the handler reads the failurepath parameter from the failing login request and uses it as the path of an internal subrequest dispatched through HttpKernelInterface::SUBREQUEST. Symfony's Firewall::onKernelRequest listener intentionally skips subrequests under the assumption they are internally generated and trusted, which also means AccessListener (the listener that evaluates accesscontrol) does not run. Because the attacker controls the target of the subrequest, an unauthenticated POST to the check path with failurepath=/admin/whatever performs a local request forgery that executes the target controller outside the firewall perimeter and returns its response to the caller. Applications that follow Symfony's recommended best practice of protecting administrative areas with broad accesscontrol rules (e.g. ^/admin requires…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6h46-9jf5-q59x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48489 Advisory: Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes IDs: CVE-2026-48489, GHSA-6h46-9jf5-q59x Record: https://patchnext.com/advisories/cve-2026-48489 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 8.0.13, 7.4.13, 6.4.41, 5.4.53; symfony/security-http 8.0.13, 7.4.13, 6.4.41, 5.4.53. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected < 5.4.53; >= 6.0.0, < 6.4.41; >= 7.0.0, < 7.4.13; >= 8.0.0, < 8.0.13; fixed in 6.4.41, 8.0.13, 7.4.13, 5.4.53 - Packagist symfony/security-http: affected < 5.4.53; >= 6.0.0, < 6.4.41; >= 7.0.0, < 7.4.13; >= 8.0.0, < 8.0.13; fixed in 6.4.41, 8.0.13, 7.4.13, 5.4.53 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/security-http: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/security-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6h46-9jf5-q59x (GitHub-reviewed advisory GHSA-6h46-9jf5-q59x lists affected ranges: Packagist symfony/security-http >=0 =6.0.0 =7.0.0 =8.0.0 =0 =6.0.0 =7.0.0 =8.0.0 <8.0.13) Commands are suggestions: review each one before running it.
Loading voting…