Apache Fory PyFory Deserialization of Untrusted Data
CVE-2026-48207GHSA-m5gw-83w2-7749
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyfory 1.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pyfory
- Affected
- >= 0.13.0, < 1.0.0
- Fixed in
- 1.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m5gw-83w2-7749 lists affected ranges: PyPI pyfory >=0.13.0 <1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m5gw-83w2-7749 lists affected ranges: PyPI pyfory >=0.13.0 <1.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-48207: 0.57% estimated exploitation activity in the next 30 days; percentile 47.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Fory PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes. This issue affects Apache Fory: from before 1.0.0. Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m5gw-83w2-7749
- Revision 2 · amended ·
Amended from osv record GHSA-m5gw-83w2-7749
- Revision 1 · created ·
Published from ghsa record GHSA-m5gw-83w2-7749
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48207 Advisory: Apache Fory PyFory Deserialization of Untrusted Data IDs: CVE-2026-48207, GHSA-m5gw-83w2-7749 Record: https://patchnext.com/advisories/cve-2026-48207 (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyfory 1.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyfory: affected >= 0.13.0, < 1.0.0; fixed in 1.0.0 ## Suggested inspection (read-only) - `python -m pip show pyfory`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyfory. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m5gw-83w2-7749 (GitHub-reviewed advisory GHSA-m5gw-83w2-7749 lists affected ranges: PyPI pyfory >=0.13.0 <1.0.0) - Verified: https://osv.dev/vulnerability/GHSA-m5gw-83w2-7749 (OSV record GHSA-m5gw-83w2-7749 lists affected ranges: PyPI pyfory >=0.13.0 <1.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…