Skip to content

← Actionable
Medium, CVSS 6.1

Slim has Reflected XSS in the HtmlErrorRenderer

CVE-2026-48157GHSA-53h4-8rc4-f539

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (slim/slim 4.15.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist slim/slim

    Affected
    >= 4.4.0, <= 4.15.1
    Fixed in
    4.15.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-48157: 0.17% estimated exploitation activity in the next 30 days; percentile 5.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If an application uses HttpException::setTitle() and/or setDescription() to include untrusted/request-derived data in the error title or description (e.g. "No products found matching '{$query}'."), an attacker could inject arbitrary HTML/JavaScript that executes in the victim's browser when they encounter an HTML error page generated by Slim. The vulnerability is present even with displayErrorDetails = false as the unescaped title and description are rendered on this error path. Built-in exceptions (HttpNotFoundException, HttpBadRequestException, etc.) ship plain-text defaults, so a vanilla Slim app with no user code is not exploitable. Only applications that feed untrusted data into setTitle() and/or setDescription() are affected. Patches The issue is fixed in 4.15.2. Workarounds Without upgrading, applications can: - Avoid passing untrusted/request-derived data into HttpException::setTitle() and setDescription(). Use static, plain-text error copy instead. - Register a custom…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-53h4-8rc4-f539

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48157

Advisory: Slim has Reflected XSS in the HtmlErrorRenderer
IDs: CVE-2026-48157, GHSA-53h4-8rc4-f539
Record: https://patchnext.com/advisories/cve-2026-48157 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: slim/slim 4.15.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist slim/slim: affected >= 4.4.0, <= 4.15.1; fixed in 4.15.2

## Suggested inspection (read-only)
- Packagist slim/slim: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on slim/slim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-53h4-8rc4-f539 (GitHub-reviewed advisory GHSA-53h4-8rc4-f539 lists affected ranges: Packagist slim/slim >=4.4.0 <=4.15.1)

Commands are suggestions: review each one before running it.

Loading voting…