Skip to content

← Actionable
High, CVSS 8.1amended

Budibase: Basic app users can exfiltrate stored REST datasource auth by rewriting datasource base URL

CVE-2026-48152GHSA-3gp5-q4jw-3v94

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.39.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-48152: 0.26% estimated exploitation activity in the next 30 days; percentile 17.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Budibase stores external REST datasource credentials server-side and documents that database credentials are applied server-side and are not exposed in the UI. The REST datasource implementation redacts stored Basic/Bearer/OAuth2 auth secrets before returning datasource data to clients. However, the single-datasource GET and PUT routes are guarded by generic TABLE READ, not by Builder/Admin permission or datasource-specific ownership/resource checks. The built-in Basic app user role maps to the WRITE permission set, which includes table read/write and query write. A Basic user can therefore read an existing REST datasource, receive redacted authConfigs values, submit an update that changes only config.url while keeping the redacted placeholders, and trigger an existing saved relative-path REST query. During update, mergeConfigs() restores the old stored secret when it sees the redaction placeholder. During query execution, Budibase prefixes the attacker-controlled datasource…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3gp5-q4jw-3v94

  2. Revision 1 · created ·

    Published from osv record GHSA-3gp5-q4jw-3v94

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48152

Advisory: Budibase: Basic app users can exfiltrate stored REST datasource auth by rewriting datasource base URL
IDs: CVE-2026-48152, GHSA-3gp5-q4jw-3v94
Record: https://patchnext.com/advisories/cve-2026-48152 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.39.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.39.0; fixed in 3.39.0

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3gp5-q4jw-3v94 (OSV record GHSA-3gp5-q4jw-3v94 lists affected ranges: npm @budibase/server >=0 <3.39.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3gp5-q4jw-3v94 (GitHub-reviewed advisory GHSA-3gp5-q4jw-3v94 lists affected ranges: npm @budibase/server >=0 <3.39.0)

Commands are suggestions: review each one before running it.

Loading voting…