Skip to content

← Actionable
Critical, CVSS 9.0amended

Budibase: Workspace-scoped builder escalates to global admin via /api/public/v1/roles/assign

CVE-2026-48150GHSA-6xp4-cf37-ppjh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.39.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:L
EPSS
  • CVE-2026-48150: 0.29% estimated exploitation activity in the next 30 days; percentile 21.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary /api/public/v1/roles/assign is guarded by the builderOrAdmin middleware, which passes any user who is a builder for the app id in the x-budibase-app-id header. That check admits both global builders and workspace-scoped builders (builder.apps set but builder.global unset). The controller then spreads the request body into the SDK call, and the SDK grants builder.global=true or admin.global=true on whichever user ids the caller supplies. Bob, a workspace-scoped builder with an API key, promotes himself or any other user to global admin with one POST. The whole flow is tenant-wide privilege escalation from an app-level role, available to anyone with an Enterprise license that unlocks the EXPANDEDPUBLICAPI feature. Details Controller (packages/server/src/api/controllers/public/roles.ts:13-17): Nothing filters assignmentProps. The request body's builder and admin keys flow directly into the SDK. SDK (packages/pro/src/sdk/publicApi/roles.ts:17-47): No check that the caller already…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6xp4-cf37-ppjh

  2. Revision 2 · amended ·

    Amended from osv record GHSA-6xp4-cf37-ppjh

  3. Revision 1 · created ·

    Published from ghsa record GHSA-6xp4-cf37-ppjh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48150

Advisory: Budibase: Workspace-scoped builder escalates to global admin via /api/public/v1/roles/assign
IDs: CVE-2026-48150, GHSA-6xp4-cf37-ppjh
Record: https://patchnext.com/advisories/cve-2026-48150 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.39.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.39.0; fixed in 3.39.0

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6xp4-cf37-ppjh (GitHub-reviewed advisory GHSA-6xp4-cf37-ppjh lists affected ranges: npm @budibase/server >=0 <3.39.0)
- Verified: https://osv.dev/vulnerability/GHSA-6xp4-cf37-ppjh (OSV record GHSA-6xp4-cf37-ppjh lists affected ranges: npm @budibase/server >=0 <3.39.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…