Budibase: Unvalidated VectorDB Host Parameter Enables SSRF
CVE-2026-48148GHSA-cv96-5348-p5p8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.35.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @budibase/server
- Affected
- < 3.35.3
- Fixed in
- 3.35.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cv96-5348-p5p8 lists affected ranges: npm @budibase/server >=0 <3.35.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cv96-5348-p5p8 lists affected ranges: npm @budibase/server >=0 <3.35.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2026-48148: 0.23% estimated exploitation activity in the next 30 days; percentile 13.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The VectorDB configuration endpoint in Budibase accepts a host parameter that undergoes no validation against internal IP ranges, reserved hostnames, or URL schemes. Any authenticated user with builder-level access can supply an arbitrary host value such as 169.254.169.254 or localhost, causing the server to initiate outbound TCP connections to internal network addresses or cloud metadata endpoints on their behalf. Details The validator responsible for VectorDB creation and updates defines the host field as Joi.string().required(), which enforces only that the value is a non-empty string. No allowlist of external hostnames, no blocklist of RFC 1918 or link-local ranges, and no scheme validation are applied before the value is forwarded to the database SDK for connection establishment. When a VectorDB entry is created or updated, the SDK uses the supplied host directly to open a TCP connection. Because the connection attempt originates from the Budibase server process, it…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cv96-5348-p5p8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-cv96-5348-p5p8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48148 Advisory: Budibase: Unvalidated VectorDB Host Parameter Enables SSRF IDs: CVE-2026-48148, GHSA-cv96-5348-p5p8 Record: https://patchnext.com/advisories/cve-2026-48148 (revision 3, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.35.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @budibase/server: affected < 3.35.3; fixed in 3.35.3 ## Suggested inspection (read-only) - `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @budibase/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cv96-5348-p5p8 (OSV record GHSA-cv96-5348-p5p8 lists affected ranges: npm @budibase/server >=0 <3.35.3 (fixed)) - Verified: https://github.com/advisories/GHSA-cv96-5348-p5p8 (GitHub-reviewed advisory GHSA-cv96-5348-p5p8 lists affected ranges: npm @budibase/server >=0 <3.35.3) Commands are suggestions: review each one before running it.
Loading voting…