Skip to content

← Actionable
High, CVSS 7.7amended

Budibase: SSRF via OAuth2 Config Validation — Missing fetchWithBlacklist Protection

CVE-2026-48146GHSA-g6qx-g4pr-92v7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.39.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-48146: 0.22% estimated exploitation activity in the next 30 days; percentile 12.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OAuth2 token fetch function in packages/server/src/sdk/workspace/oauth2/utils.ts (line 59) uses raw fetch(config.url) with no SSRF protection. The safe wrapper fetchWithBlacklist() exists in the same codebase and is used in every other outbound HTTP call (automation steps, plugin downloads, object store), but was not applied to the OAuth2 token endpoint. A user with BUILDER role can point the OAuth2 token URL to internal services (CouchDB, cloud metadata) to exfiltrate sensitive data. Details Vulnerable code — packages/server/src/sdk/workspace/oauth2/utils.ts:59: Safe wrapper used everywhere else — packages/backend-core/src/utils/outboundFetch.ts: Where fetchWithBlacklist IS used (consistency gap proof): - automations/steps/discord.ts — Discord webhook - automations/steps/slack.ts — Slack webhook - automations/steps/make.ts — Make.com integration - automations/steps/n8n.ts — n8n integration - automations/steps/zapier.ts — Zapier integration -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g6qx-g4pr-92v7

  2. Revision 1 · created ·

    Published from osv record GHSA-g6qx-g4pr-92v7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48146

Advisory: Budibase: SSRF via OAuth2 Config Validation — Missing fetchWithBlacklist Protection
IDs: CVE-2026-48146, GHSA-g6qx-g4pr-92v7
Record: https://patchnext.com/advisories/cve-2026-48146 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.39.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.39.0; fixed in 3.39.0

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g6qx-g4pr-92v7 (OSV record GHSA-g6qx-g4pr-92v7 lists affected ranges: npm @budibase/server >=0 <3.39.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g6qx-g4pr-92v7 (GitHub-reviewed advisory GHSA-g6qx-g4pr-92v7 lists affected ranges: npm @budibase/server >=0 <3.39.0)

Commands are suggestions: review each one before running it.

Loading voting…