UAParser.js: Unbounded Sec-CH-UA-Model parsing can trigger ReDoS in withClientHints()
CVE-2026-48125GHSA-9h5v-pfqq-x599
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ua-parser-js 2.0.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ua-parser-js
- Affected
- >= 2.0.1, < 2.0.10
- Fixed in
- 2.0.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9h5v-pfqq-x599 lists affected ranges: npm ua-parser-js >=2.0.1 <2.0.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9h5v-pfqq-x599 lists affected ranges: npm ua-parser-js >=2.0.1 <2.0.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-48125: 0.52% estimated exploitation activity in the next 30 days; percentile 44.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A regular expression denial-of-service (ReDoS) vulnerability has been discovered in ua-parser-js when using the Client Hints API. By sending a crafted Sec-CH-UA-Model header to an application that calls UAParser(headers).withClientHints(), an attacker can cause the parser to spend excessive CPU time due to catastrophic backtracking in the device regex: Unlike when using the User-Agent value, which has a hard limit of UAMAXLENGTH = 500, when using Client Hints, values are copied without a length limit before being passed into regex parsing. PoC Impact This vulnerability allows an unauthenticated attacker to trigger a denial-of-service condition in any server-side application that uses UAParser(headers).withClientHints(). A single request with a ~32,000-character model value can consume over 400ms of CPU time, with parsing time growing polynomially with input length. The impact is availability only, there is no confidentiality or integrity impact. Affected Versions ua-parser-js…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9h5v-pfqq-x599
- Revision 1 · created ·
Published from osv record GHSA-9h5v-pfqq-x599
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48125 Advisory: UAParser.js: Unbounded `Sec-CH-UA-Model` parsing can trigger ReDoS in `withClientHints()` IDs: CVE-2026-48125, GHSA-9h5v-pfqq-x599 Record: https://patchnext.com/advisories/cve-2026-48125 (revision 2, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ua-parser-js 2.0.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ua-parser-js: affected >= 2.0.1, < 2.0.10; fixed in 2.0.10 ## Suggested inspection (read-only) - `npm ls ua-parser-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ua-parser-js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9h5v-pfqq-x599 (OSV record GHSA-9h5v-pfqq-x599 lists affected ranges: npm ua-parser-js >=2.0.1 <2.0.10 (fixed)) - Verified: https://github.com/advisories/GHSA-9h5v-pfqq-x599 (GitHub-reviewed advisory GHSA-9h5v-pfqq-x599 lists affected ranges: npm ua-parser-js >=2.0.1 <2.0.10) Commands are suggestions: review each one before running it.
Loading voting…