LangGraph has NoSQL parameter injection in MongoDBSaver, allowing cross-tenant state access
CVE-2026-48121GHSA-98xf-r82g-9mhx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@langchain/langgraph-checkpoint-mongodb 1.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @langchain/langgraph-checkpoint-mongodb
- Affected
- <= 1.3.0
- Fixed in
- 1.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-98xf-r82g-9mhx lists affected ranges: npm @langchain/langgraph-checkpoint-mongodb >=0 <1.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98xf-r82g-9mhx lists affected ranges: npm @langchain/langgraph-checkpoint-mongodb >=0 <=1.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-48121: 0.36% estimated exploitation activity in the next 30 days; percentile 29.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A NoSQL injection vulnerability existed in MongoDBSaver where checkpoint identifier fields from config.configurable were used in MongoDB queries without strict type enforcement. In vulnerable versions, attacker-controlled object payloads (for example MongoDB operators like $gt and $ne) could be interpreted as query operators instead of literal identifier values. This could bypass intended thread scoping and return checkpoints from other tenants. Attack surface The vulnerable path was in MongoDBSaver.getTuple(), where threadid, checkpointns, and checkpointid were used in MongoDB find() queries. The same unvalidated values were then reused to fetch pending writes. Applications were exposed when untrusted input was forwarded into config.configurable (for example, directly from request bodies or query parameters) without string coercion or schema validation. Who is affected? Applications are vulnerable if they: - Use @langchain/langgraph-checkpoint-mongodb with multi-tenant or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-98xf-r82g-9mhx
- Revision 1 · created ·
Published from osv record GHSA-98xf-r82g-9mhx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48121 Advisory: LangGraph has NoSQL parameter injection in MongoDBSaver, allowing cross-tenant state access IDs: CVE-2026-48121, GHSA-98xf-r82g-9mhx Record: https://patchnext.com/advisories/cve-2026-48121 (revision 2, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @langchain/langgraph-checkpoint-mongodb 1.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @langchain/langgraph-checkpoint-mongodb: affected <= 1.3.0; fixed in 1.3.1 ## Suggested inspection (read-only) - `npm ls @langchain/langgraph-checkpoint-mongodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @langchain/langgraph-checkpoint-mongodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-98xf-r82g-9mhx (OSV record GHSA-98xf-r82g-9mhx lists affected ranges: npm @langchain/langgraph-checkpoint-mongodb >=0 <1.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-98xf-r82g-9mhx (GitHub-reviewed advisory GHSA-98xf-r82g-9mhx lists affected ranges: npm @langchain/langgraph-checkpoint-mongodb >=0 <=1.3.0) Commands are suggestions: review each one before running it.
Loading voting…