Skip to content

← Actionable
High, CVSS 7.5

Russh SSH message fields were decoded through allocation-first parsers before field-specific bounds

CVE-2026-48110GHSA-4r3c-5hpg-58qr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (russh 0.61.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io russh

    Affected
    >= 0.34.0, < 0.61.0
    Fixed in
    0.61.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-48110: 0.37% estimated exploitation activity in the next 30 days; percentile 30.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SSH message fields were decoded through allocation-first parsers before field-specific bounds Summary Several russh client and server message handlers decoded attacker-controlled SSH strings, name-lists, and byte fields into owned allocations before applying field-specific bounds. A remote SSH peer could send oversized, high-fanout, or malformed length-prefixed fields and make the library allocate, attempt to allocate, or split data before rejecting input that should have been rejected earlier. Affected Versions Oldest verified exploitable stable release: russh 0.34.0. - Historical stronger case: russh = 0.34.0, < 0.58.0. These releases have the allocation-first KEXINIT field parsing issue and still use CryptoVec for inbound packet/decompression buffers. A peer can combine negotiated RFC zlib, rekey, compressed KEXINIT expansion, historical CryptoVec decompression growth, and KEXINIT name-list fanout. - Current maintained-line case: russh = 0.58.0, including 0.60.2. These releases…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4r3c-5hpg-58qr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48110

Advisory: Russh SSH message fields were decoded through allocation-first parsers before field-specific bounds
IDs: CVE-2026-48110, GHSA-4r3c-5hpg-58qr
Record: https://patchnext.com/advisories/cve-2026-48110 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: russh 0.61.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io russh: affected >= 0.34.0, < 0.61.0; fixed in 0.61.0

## Suggested inspection (read-only)
- crates.io russh: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on russh.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4r3c-5hpg-58qr (GitHub-reviewed advisory GHSA-4r3c-5hpg-58qr lists affected ranges: crates.io russh >=0.34.0 <0.61.0)

Commands are suggestions: review each one before running it.

Loading voting…