Russh: Unchecked keyboard-interactive prompt count in client auth path
CVE-2026-48107GHSA-g9g7-5cgw-6v28
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (russh 0.61.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io russh
- Affected
- >= 0.37.0, < 0.61.0
- Fixed in
- 0.61.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g9g7-5cgw-6v28 lists affected ranges: crates.io russh >=0.37.0 <0.61.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-48107: 0.23% estimated exploitation activity in the next 30 days; percentile 14.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In the russh client keyboard-interactive authentication path, a malicious SSH server could send a USERAUTHINFOREQUEST with an attacker-controlled prompt count, and the client would use that raw count directly in Vec::withcapacity(...) before validating that enough prompt data was actually present in the packet. This is a client-side denial-of-service / resource-exhaustion issue on the keyboard-interactive auth path. Details The vulnerable code path is in: - russh/src/client/encrypted.rs When the client is in CurrentRequest::KeyboardInteractive state and receives SSHMSGUSERAUTHINFOREQUEST, it parses: 1. name 2. instructions 3. language tag 4. nprompts Before the fix, the code then did: That means a malicious server could advertise an enormous nprompts value even if the packet contained no prompt bodies at all. The fix rejects inconsistent prompt counts before allocating: Each prompt needs at least 4 bytes of string length plus 1 byte of echo flag, so remaininglen() / 5 is a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g9g7-5cgw-6v28
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48107 Advisory: Russh: Unchecked keyboard-interactive prompt count in client auth path IDs: CVE-2026-48107, GHSA-g9g7-5cgw-6v28 Record: https://patchnext.com/advisories/cve-2026-48107 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: russh 0.61.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io russh: affected >= 0.37.0, < 0.61.0; fixed in 0.61.0 ## Suggested inspection (read-only) - crates.io russh: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on russh. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g9g7-5cgw-6v28 (GitHub-reviewed advisory GHSA-g9g7-5cgw-6v28 lists affected ranges: crates.io russh >=0.37.0 <0.61.0) Commands are suggestions: review each one before running it.
Loading voting…