Skip to content

← Actionable
High, CVSS 7.1

DevGuard has improper authorization on public assets

CVE-2026-48089GHSA-6p54-fw2f-q7gf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/l3montree-dev/devguard 1.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:N · score source
EPSS
  • CVE-2026-48089: 0.36% estimated exploitation activity in the next 30 days; percentile 30.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact On a DevGuard API instance with one or more public assets, any authenticated user — including users from a different organization with no membership or role in the affected org/project — can create, update, reapply, and delete VEX rules on those public assets. The same flaw affects the other vulnerability-triage write endpoints exposed under a public asset, including: - VEX rule create / update / reapply / delete - Dependency-vuln event creation (accept / reject / mitigate decisions), batch event creation, vuln sync, and mitigation - License risk creation - External reference writes - Artifact creation and license refresh The attacker needs a valid account on the instance, but no membership in the victim organization, project, or asset is required. Security impact is primarily to integrity of the vulnerability picture of public assets: an attacker can mark CVEs as false-positive, silence vulnerabilities, attach misleading justifications, or delete legitimate triage rules —…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6p54-fw2f-q7gf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48089

Advisory: DevGuard has improper authorization on public assets
IDs: CVE-2026-48089, GHSA-6p54-fw2f-q7gf
Record: https://patchnext.com/advisories/cve-2026-48089 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/l3montree-dev/devguard 1.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/l3montree-dev/devguard: affected < 1.4.2; fixed in 1.4.2

## Suggested inspection (read-only)
- Go github.com/l3montree-dev/devguard: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/l3montree-dev/devguard.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6p54-fw2f-q7gf (GitHub-reviewed advisory GHSA-6p54-fw2f-q7gf lists affected ranges: Go github.com/l3montree-dev/devguard >=0 <1.4.2)

Commands are suggestions: review each one before running it.

Loading voting…