Skip to content

← Actionable
High, CVSS 7.5amended

@grpc/grpc-js: A malformed request can cause a server crash

CVE-2026-48068GHSA-5375-pq7m-f5r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@grpc/grpc-js 1.14.4, 1.13.5, 1.12.7, 1.11.4, 1.10.12, 1.9.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @grpc/grpc-js

    Affected
    < 1.9.16>= 1.10.0, < 1.10.12>= 1.11.0, < 1.11.4>= 1.12.0, < 1.12.7>= 1.13.0, < 1.13.5>= 1.14.0, < 1.14.4
    Fixed in
    1.13.5, 1.14.4, 1.12.7, 1.9.16, 1.10.12, 1.11.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-48068: 0.88% estimated exploitation activity in the next 30 days; percentile 59.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An invalid incoming HTTP/2 stream initiation can cause a server process to crash. This affects all servers created using @grpc/grpc-js. Patches The following version have fixes for this vulnerability: - 1.9.16 - 1.10.12 - 1.11.4 - 1.12.7 - 1.13.5 - 1.14.4 Workarounds There is no workaround.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5375-pq7m-f5r2

  2. Revision 1 · created ·

    Published from osv record GHSA-5375-pq7m-f5r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48068

Advisory: @grpc/grpc-js: A malformed request can cause a server crash
IDs: CVE-2026-48068, GHSA-5375-pq7m-f5r2
Record: https://patchnext.com/advisories/cve-2026-48068 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @grpc/grpc-js 1.14.4, 1.13.5, 1.12.7, 1.11.4, 1.10.12, 1.9.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @grpc/grpc-js: affected < 1.9.16; >= 1.10.0, < 1.10.12; >= 1.11.0, < 1.11.4; >= 1.12.0, < 1.12.7; >= 1.13.0, < 1.13.5; >= 1.14.0, < 1.14.4; fixed in 1.13.5, 1.14.4, 1.12.7, 1.9.16, 1.10.12, 1.11.4

## Suggested inspection (read-only)
- `npm ls @grpc/grpc-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @grpc/grpc-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5375-pq7m-f5r2 (OSV record GHSA-5375-pq7m-f5r2 lists affected ranges: npm @grpc/grpc-js >=0 =1.10.0 =1.11.0 =1.12.0 =1.13.0 =1.14.0 <1.14.4 (fixed))
- Verified: https://github.com/advisories/GHSA-5375-pq7m-f5r2 (GitHub-reviewed advisory GHSA-5375-pq7m-f5r2 lists affected ranges: npm @grpc/grpc-js >=0 =1.10.0 =1.11.0 =1.12.0 =1.13.0 =1.14.0 <1.14.4)

Commands are suggestions: review each one before running it.

Loading voting…