Filament has inconsistent scope enforcement for its AttachAction and AssociateAction Select fields
CVE-2026-48067GHSA-7q3w-xqjw-g3cr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (filament/actions 5.6.4, 4.11.4; filament/tables 3.3.51), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist filament/actions
- Affected
- >= 4.0.0, <= 4.11.3>= 5.0.0, <= 5.6.3
- Fixed in
- 4.11.4, 5.6.4
Packagist filament/tables
- Affected
- >= 3.0.0, <= 3.3.50
- Fixed in
- 3.3.51
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7q3w-xqjw-g3cr lists affected ranges: Packagist filament/tables >=3.0.0 =4.0.0 =5.0.0 <=5.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-48067: 0.30% estimated exploitation activity in the next 30 days; percentile 22.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The recordSelectOptionsQuery() method may be used to scope the options available in the Select field for AttachAction and AssociateAction. However, the built-in validation rule for these fields did not apply the same scope. As a result, a user who can trigger these actions could tamper with the Livewire component's state and submit an out-of-scope value.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7q3w-xqjw-g3cr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48067 Advisory: Filament has inconsistent scope enforcement for its AttachAction and AssociateAction Select fields IDs: CVE-2026-48067, GHSA-7q3w-xqjw-g3cr Record: https://patchnext.com/advisories/cve-2026-48067 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: filament/actions 5.6.4, 4.11.4; filament/tables 3.3.51. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist filament/actions: affected >= 4.0.0, <= 4.11.3; >= 5.0.0, <= 5.6.3; fixed in 4.11.4, 5.6.4 - Packagist filament/tables: affected >= 3.0.0, <= 3.3.50; fixed in 3.3.51 ## Suggested inspection (read-only) - Packagist filament/actions: check the installed version with your package manager. - Packagist filament/tables: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on filament/actions, filament/tables. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7q3w-xqjw-g3cr (GitHub-reviewed advisory GHSA-7q3w-xqjw-g3cr lists affected ranges: Packagist filament/tables >=3.0.0 =4.0.0 =5.0.0 <=5.6.3) Commands are suggestions: review each one before running it.
Loading voting…