Skip to content

← Actionable
Critical, CVSS 9.3amended

Baileys has message upsert / hist sync spoofing and app state corruption when using maliciously crafted protocolMessage payload

CVE-2026-48063GHSA-qvv5-jq5g-4cgg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@whiskeysockets/baileys 7.0.0-rc12, 6.7.22; baileys 7.0.0-rc12, 6.7.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @whiskeysockets/baileys

    Affected
    < 6.7.22>= 7.0.0-rc.1, < 7.0.0-rc12
    Fixed in
    7.0.0-rc12, 6.7.22
  • npm baileys

    Affected
    < 6.7.22>= 7.0.0-rc.1, < 7.0.0-rc12
    Fixed in
    7.0.0-rc12, 6.7.22

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-48063: 0.22% estimated exploitation activity in the next 30 days; percentile 12.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any baileys session under the latest version (< 7.0.0-rc12, and < 6.7.22) can be sent a malicious payload via the placeholderResendMessage and trigger a fake messages.upsert event with a fake message key and payload. This allows anyone to spoof messages. The same exploit also allows an attacker to corrupt the app state sync system by sending fake key shares, and also allows for history sync spoofing which also serves the same problem, injecting fake previous context or "on-demand" sync. Patches https://github.com/WhiskeySockets/Baileys/commit/3beb08eecfcb4e65722e674034bd84fb11a9de35 This commit has patched the issue, and a version tag has been released under 7.0.0 (6.7.22) for those still on Baileys v6. A new Baileys version, v7.0.0-rc12, has been released to remediate this. Workarounds There are no real workarounds other than dropping messages.upsert events that contain a requestId field, turning off automatic history sync (shouldSyncHistoryMessage: () = false) in socket…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-qvv5-jq5g-4cgg

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-qvv5-jq5g-4cgg

  4. Revision 1 · created ·

    Published from ghsa record GHSA-qvv5-jq5g-4cgg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48063

Advisory: Baileys has message upsert / hist sync spoofing and app state corruption when using maliciously crafted protocolMessage payload
IDs: CVE-2026-48063, GHSA-qvv5-jq5g-4cgg
Record: https://patchnext.com/advisories/cve-2026-48063 (revision 4, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @whiskeysockets/baileys 7.0.0-rc12, 6.7.22; baileys 7.0.0-rc12, 6.7.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @whiskeysockets/baileys: affected < 6.7.22; >= 7.0.0-rc.1, < 7.0.0-rc12; fixed in 7.0.0-rc12, 6.7.22
- npm baileys: affected < 6.7.22; >= 7.0.0-rc.1, < 7.0.0-rc12; fixed in 7.0.0-rc12, 6.7.22

## Suggested inspection (read-only)
- `npm ls @whiskeysockets/baileys --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls baileys --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @whiskeysockets/baileys, baileys.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qvv5-jq5g-4cgg (GitHub-reviewed advisory GHSA-qvv5-jq5g-4cgg lists affected ranges: npm baileys >=0 =7.0.0-rc.1 =0 =7.0.0-rc.1 <7.0.0-rc12)
- Verified: https://osv.dev/vulnerability/GHSA-qvv5-jq5g-4cgg (OSV record GHSA-qvv5-jq5g-4cgg lists affected ranges: npm baileys >=0 =7.0.0-rc.1 =0 =7.0.0-rc.1 <7.0.0-rc12 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…