Skip to content

← Actionable
High, CVSS 8.1amended

Litestar has HTML Injection Through its CSRF Token

CVE-2026-48060GHSA-542p-wvx7-72m4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (litestar 2.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI litestar

    Affected
    < 2.22.0
    Fixed in
    2.22.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-48060: 0.35% estimated exploitation activity in the next 30 days; percentile 28.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Litestar instances which use a template engine in conjunction with CSRF protection are vulnerable to HTML Injection which can be escalated to Cross Site Scripting due to the contents of the CSRF cookie being excluded from automatic escaping by the template engine when configured inline with documentation recommendations. We used the latest Litestar version available via PyPI for this disclosure. At the time of writing, that is version 2.21.0 and we have not validated this against the current latest commit on the main branch. Special Configurations Required For a web application to be vulnerable to this issue, it must: - Use templates to render the content which is returned to the user (e.g. Jinja, Mako, MiniJinja) - Have CSRF protection enabled - Have CSRF inputs enabled (i.e. a hidden form field which contains the CSRF token) Links to relevant documentation for the above configurations: - https://docs.litestar.dev/2/usage/templating.html -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-542p-wvx7-72m4

  2. Revision 1 · created ·

    Published from osv record GHSA-542p-wvx7-72m4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48060

Advisory: Litestar has HTML Injection Through its CSRF Token
IDs: CVE-2026-48060, GHSA-542p-wvx7-72m4
Record: https://patchnext.com/advisories/cve-2026-48060 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: litestar 2.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI litestar: affected < 2.22.0; fixed in 2.22.0

## Suggested inspection (read-only)
- `python -m pip show litestar`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on litestar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-542p-wvx7-72m4 (OSV record GHSA-542p-wvx7-72m4 lists affected ranges: PyPI litestar >=0 <2.22.0 (fixed))
- Verified: https://github.com/advisories/GHSA-542p-wvx7-72m4 (GitHub-reviewed advisory GHSA-542p-wvx7-72m4 lists affected ranges: PyPI litestar >=0 <2.22.0)

Commands are suggestions: review each one before running it.

Loading voting…