Skip to content

← Actionable
High, CVSS 8.8amended

OpenZeppelin Contracts Wizard has Code Injection in Generated Hardhat and Foundry Tests via Unsanitized opts.name / opts.uri

CVE-2026-48054GHSA-4x76-22x2-rx8v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/wizard 0.10.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-48054: 0.64% estimated exploitation activity in the next 30 days; percentile 50.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OpenZeppelin Contracts Wizard generated Hardhat (test/test.ts) and Foundry (test/<Name.t.sol) example test files that interpolated user-supplied strings (opts.name, opts.uri) into the test source without escaping. A crafted input could produce a generated test file in which the input string broke out of its surrounding literal and was parsed as code, executing when a developer ran npm test or forge test on the downloaded project. Impact - Users of the hosted Wizard at https://wizard.openzeppelin.com: no action required. The site has been redeployed with the fix. - Users of @openzeppelin/wizard via the documented public API: not affected. The vulnerable functions (zipHardhat, zipFoundry) are not part of the package's documented public exports. - Callers of zipHardhat / zipFoundry who forward externally-controlled strings into opts.name / opts.uri: upgrade to 0.10.9. Patches Fixed in @openzeppelin/wizard@0.10.9.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4x76-22x2-rx8v

  2. Revision 1 · created ·

    Published from osv record GHSA-4x76-22x2-rx8v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48054

Advisory: OpenZeppelin Contracts Wizard has Code Injection in Generated Hardhat and Foundry Tests via Unsanitized opts.name / opts.uri
IDs: CVE-2026-48054, GHSA-4x76-22x2-rx8v
Record: https://patchnext.com/advisories/cve-2026-48054 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/wizard 0.10.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openzeppelin/wizard: affected <= 0.10.8; fixed in 0.10.9

## Suggested inspection (read-only)
- `npm ls @openzeppelin/wizard --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openzeppelin/wizard.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4x76-22x2-rx8v (OSV record GHSA-4x76-22x2-rx8v lists affected ranges: npm @openzeppelin/wizard >=0 <0.10.9 (fixed))
- Verified: https://github.com/advisories/GHSA-4x76-22x2-rx8v (GitHub-reviewed advisory GHSA-4x76-22x2-rx8v lists affected ranges: npm @openzeppelin/wizard >=0 <=0.10.8)

Commands are suggestions: review each one before running it.

Loading voting…