Kolibri has Unauthenticated Server-Side Request Forgery (SSRF) in RemoteFacilityUserViewset
CVE-2026-48053GHSA-4mj9-pf4r-cqrc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kolibri 0.19.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI kolibri
- Affected
- <= 0.19.3
- Fixed in
- 0.19.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4mj9-pf4r-cqrc lists affected ranges: PyPI kolibri >=0 <0.19.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mj9-pf4r-cqrc lists affected ranges: PyPI kolibri >=0 <=0.19.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2026-48053: 0.38% estimated exploitation activity in the next 30 days; percentile 32.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Several Kolibri API endpoints accept an unvalidated baseurl parameter and fetch attacker-controlled URLs from the Kolibri server, reflecting the response body back to the caller. The original report identified two endpoints on the RemoteFacilityUser viewsets; remediation review found two further reflection points on the same pattern. The GET endpoint was unauthenticated. Affected endpoints Reported: - GET /api/auth/remotefacilityuser → RemoteFacilityUserViewset (kolibri/core/auth/api.py:1570). No authentication required. - POST /api/auth/remotefacilityauthenticateduserinfo → RemoteFacilityUserAuthenticatedViewset (kolibri/core/auth/api.py:1594). Authentication is checked against the remote server rather than the local Kolibri. Found during remediation: - POST /api/public/setupwizard/loddata → setup wizard's remote-signup proxy (kolibri/plugins/setupwizard/api.py). Reachable on unprovisioned devices. - GET /api/public/networklocation/<id/facilities/ →…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4mj9-pf4r-cqrc
- Revision 1 · created ·
Published from osv record GHSA-4mj9-pf4r-cqrc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48053 Advisory: Kolibri has Unauthenticated Server-Side Request Forgery (SSRF) in RemoteFacilityUserViewset IDs: CVE-2026-48053, GHSA-4mj9-pf4r-cqrc Record: https://patchnext.com/advisories/cve-2026-48053 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kolibri 0.19.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI kolibri: affected <= 0.19.3; fixed in 0.19.4 ## Suggested inspection (read-only) - `python -m pip show kolibri`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kolibri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4mj9-pf4r-cqrc (OSV record GHSA-4mj9-pf4r-cqrc lists affected ranges: PyPI kolibri >=0 <0.19.4 (fixed)) - Verified: https://github.com/advisories/GHSA-4mj9-pf4r-cqrc (GitHub-reviewed advisory GHSA-4mj9-pf4r-cqrc lists affected ranges: PyPI kolibri >=0 <=0.19.3) Commands are suggestions: review each one before running it.
Loading voting…