XWiki Platform vulnerable to potential arbitrary file writing using path traversal from (subwiki) admin
CVE-2026-48047GHSA-vgwr-23fq-pr7g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-webjars-api 17.10.3, 17.4.9, 16.10.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-webjars-api
- Affected
- >= 9.6-rc-1, < 16.10.17>= 17.0.0-rc-1, < 17.4.9>= 17.5.0-rc-1, < 17.10.3
- Fixed in
- 16.10.17, 17.4.9, 17.10.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vgwr-23fq-pr7g lists affected ranges: Maven org.xwiki.platform:xwiki-platform-webjars-api >=9.6-rc-1 =17.0.0-rc-1 =17.5.0-rc-1 <17.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-48047: 0.65% estimated exploitation activity in the next 30 days; percentile 51.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A potential path traversal vulnerability allow an attacker who manages to get a malicious WebJar extension installed on the wiki to write arbitrary files. While the consequences could be severe like overriding configuration files and setting the superadmin password, the attack first requires that the attacker already has admin access to at least a subwiki to be able to install a malicious extension. Further, the attacker needs to publish a malicious extension in an extension repository that is configured in the instance. Patches This vulnerability has been patched in XWiki 16.10.17, 17.4.9, 17.10.3, and 18.0.0RC1. Workarounds XWiki is not aware of any workarounds except for being careful whom developers grant script and admin rights to. Resources https://jira.xwiki.org/browse/XWIKI-23902 https://github.com/xwiki/xwiki-platform/commit/9f747fcd3200259a1de51957d3f5f6acc8e3816c
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vgwr-23fq-pr7g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48047 Advisory: XWiki Platform vulnerable to potential arbitrary file writing using path traversal from (subwiki) admin IDs: CVE-2026-48047, GHSA-vgwr-23fq-pr7g Record: https://patchnext.com/advisories/cve-2026-48047 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-webjars-api 17.10.3, 17.4.9, 16.10.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-webjars-api: affected >= 9.6-rc-1, < 16.10.17; >= 17.0.0-rc-1, < 17.4.9; >= 17.5.0-rc-1, < 17.10.3; fixed in 16.10.17, 17.4.9, 17.10.3 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-webjars-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-webjars-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vgwr-23fq-pr7g (GitHub-reviewed advisory GHSA-vgwr-23fq-pr7g lists affected ranges: Maven org.xwiki.platform:xwiki-platform-webjars-api >=9.6-rc-1 =17.0.0-rc-1 =17.5.0-rc-1 <17.10.3) Commands are suggestions: review each one before running it.
Loading voting…