Skip to content

← Actionable
Critical, CVSS 9.1amended

Meta Ads MCP: Unauthenticated HTTP MCP Tool Execution Leaks Operator Meta Access Token

CVE-2026-48039GHSA-9gw6-46qc-99vr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (meta-ads-mcp 1.0.109), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-48039: 0.59% estimated exploitation activity in the next 30 days; percentile 48.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unauthenticated HTTP MCP Tool Execution Leaks Operator Meta Access Token | Field | Value | | ---------------- | ----- | | Repository | pipeboard-co/meta-ads-mcp | | Affected version | ≤ 1.0.101 (commit 496c988 ~ 7d14226); Versions 1.0.102–1.0.105 lack git tags, so patch status is unconfirmed. | | Vulnerability | CWE-287 — Improper Authentication | | Severity | Critical | | CVSS 3.1 | 9.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N) | Summary AuthInjectionMiddleware.dispatch() at httpauthintegration.py:272 unconditionally forwards unauthenticated Streamable HTTP requests to downstream MCP tool handlers without issuing a 401 response, allowing any network-reachable caller to invoke MCP tools without authentication. When no per-request credential is present, tool handlers fall back to the METAACCESSTOKEN environment variable, and when the downstream Meta Graph API call fails, api.py:263–269 serialises the raw httpx request URL—including the operator's accesstoken as a query…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9gw6-46qc-99vr

  2. Revision 2 · amended ·

    Amended from osv record GHSA-9gw6-46qc-99vr

  3. Revision 1 · created ·

    Published from ghsa record GHSA-9gw6-46qc-99vr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48039

Advisory: Meta Ads MCP: Unauthenticated HTTP MCP Tool Execution Leaks Operator Meta Access Token
IDs: CVE-2026-48039, GHSA-9gw6-46qc-99vr
Record: https://patchnext.com/advisories/cve-2026-48039 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: meta-ads-mcp 1.0.109. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI meta-ads-mcp: affected <= 1.0.108; fixed in 1.0.109

## Suggested inspection (read-only)
- `python -m pip show meta-ads-mcp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on meta-ads-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9gw6-46qc-99vr (GitHub-reviewed advisory GHSA-9gw6-46qc-99vr lists affected ranges: PyPI meta-ads-mcp >=0 <=1.0.108)
- Verified: https://osv.dev/vulnerability/GHSA-9gw6-46qc-99vr (OSV record GHSA-9gw6-46qc-99vr lists affected ranges: PyPI meta-ads-mcp >=0 <1.0.109 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…