Skip to content

← Actionable
Medium, CVSS 6.3amended

@hulumi/baseline: AccountFoundation reuse paths silently downgrade GuardDuty / Security Hub posture

CVE-2026-48037GHSA-cj8g-prcm-mfg5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hulumi/baseline 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:L/SI:H/SA:N · score source
EPSS
  • CVE-2026-48037: 0.45% estimated exploitation activity in the next 30 days; percentile 39.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected: @hulumi/baseline < 1.4.0 — Fixed in: 1.4.0 — Severity: Medium — CWE-693 (Protection Mechanism Failure) Summary AccountFoundation can either create AWS detective services (GuardDuty for threat detection, Security Hub for compliance dashboards) or reuse pre-existing ones via opt-in flags. The reuse paths just imported the existing resources and reported success — they never checked whether the existing services were actually doing their job. 1. GuardDuty reuse. If the existing detector was suspended, or set to the slower 6-hour publishing cadence instead of the baseline 15-minute one, or otherwise misconfigured — Hulumi never noticed. The deployment succeeded with a misleadingly-positive guardDutyDetectorId output as if the baseline were active. 2. Security Hub reuse. Although the account import was read-only, Hulumi unconditionally created the CIS / NIST StandardsSubscription resources with default delete behaviour. Pulumi then treated those subscriptions as its own — a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cj8g-prcm-mfg5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cj8g-prcm-mfg5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48037

Advisory: @hulumi/baseline: AccountFoundation reuse paths silently downgrade GuardDuty / Security Hub posture
IDs: CVE-2026-48037, GHSA-cj8g-prcm-mfg5
Record: https://patchnext.com/advisories/cve-2026-48037 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hulumi/baseline 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hulumi/baseline: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `npm ls @hulumi/baseline --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hulumi/baseline.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cj8g-prcm-mfg5 (OSV record GHSA-cj8g-prcm-mfg5 lists affected ranges: npm @hulumi/baseline >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cj8g-prcm-mfg5 (GitHub-reviewed advisory GHSA-cj8g-prcm-mfg5 lists affected ranges: npm @hulumi/baseline >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…