@hulumi/drift: Drift classifier fails open on adapter errors and over-promotes Mixed verdicts
CVE-2026-48036GHSA-32g3-35g9-wc9g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hulumi/drift 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @hulumi/drift
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-32g3-35g9-wc9g lists affected ranges: npm @hulumi/drift >=0 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-32g3-35g9-wc9g lists affected ranges: npm @hulumi/drift >=0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L · score source
- EPSS
- CVE-2026-48036: 0.51% estimated exploitation activity in the next 30 days; percentile 43.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected: @hulumi/drift < 1.4.0 — Fixed in: 1.4.0 — Severity: Medium — CWE-755 (Improper Handling of Exceptional Conditions) Summary @hulumi/drift runs four adapters that each ask a different question about whether a resource has drifted (Pulumi-state diff, provider-version change, CloudTrail event, etc.). A classifier combines the adapters' answers into a verdict like None / none, ConsoleBreakGlass / high, or Mixed / high, and caches the verdict for 6 hours by default. Two related bugs from one root cause — the classifier only read each adapter's detected: true/false field and ignored whether the adapter itself succeeded: 1. Cached "all clear" on adapter failure. When an adapter failed (e.g. transient network error from the Automation API), the classifier read detected: false, concluded "no drift", and cached the verdict as None / none for 6 hours. A single transient failure could mask real console-break-glass mutations for the rest of the window. 2. Mixed verdicts without real…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-32g3-35g9-wc9g
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-32g3-35g9-wc9g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48036 Advisory: @hulumi/drift: Drift classifier fails open on adapter errors and over-promotes Mixed verdicts IDs: CVE-2026-48036, GHSA-32g3-35g9-wc9g Record: https://patchnext.com/advisories/cve-2026-48036 (revision 3, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @hulumi/drift 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @hulumi/drift: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `npm ls @hulumi/drift --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @hulumi/drift. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-32g3-35g9-wc9g (OSV record GHSA-32g3-35g9-wc9g lists affected ranges: npm @hulumi/drift >=0 <1.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-32g3-35g9-wc9g (GitHub-reviewed advisory GHSA-32g3-35g9-wc9g lists affected ranges: npm @hulumi/drift >=0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…