Skip to content

← Actionable
High, CVSS 8.5amended

@hulumi/policies has a HULUMI-H5 bypass via decoy sibling resources targeting a different bucket

CVE-2026-48034GHSA-9vc9-4jv3-rf86

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hulumi/policies 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:L · score source
EPSS
  • CVE-2026-48034: 0.45% estimated exploitation activity in the next 30 days; percentile 39.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected: @hulumi/policies < 1.4.0 — Fixed in: 1.4.0 — Severity: High — CWE-284 (Improper Access Control) Summary HULUMI-H1 forbids raw aws:s3:Bucket outside of Hulumi's SecureBucket component, with one exemption: a raw bucket that's a child of a SecureBucket is allowed because the component is responsible for the hardening. HULUMI-H5 is the defence-in-depth check that closes the H1 exemption — for any raw bucket claiming it, H5 verifies the five hardening sibling resources a real SecureBucket always emits (public-access block, SSE-KMS, ownership controls, versioning, TLS-only bucket policy) are actually present. The bug: H5 only checked the siblings' types. It never verified that those siblings actually applied to the bucket being exempted. A consumer (or compromised PR) could pair an unhardened raw bucket with five hardening sibling resources whose bucket property pointed at a completely different bucket, and H5 would report no violation while the actual bucket shipped with zero…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9vc9-4jv3-rf86

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9vc9-4jv3-rf86

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48034

Advisory: @hulumi/policies has a HULUMI-H5 bypass via decoy sibling resources targeting a different bucket
IDs: CVE-2026-48034, GHSA-9vc9-4jv3-rf86
Record: https://patchnext.com/advisories/cve-2026-48034 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hulumi/policies 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hulumi/policies: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `npm ls @hulumi/policies --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hulumi/policies.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9vc9-4jv3-rf86 (OSV record GHSA-9vc9-4jv3-rf86 lists affected ranges: npm @hulumi/policies >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9vc9-4jv3-rf86 (GitHub-reviewed advisory GHSA-9vc9-4jv3-rf86 lists affected ranges: npm @hulumi/policies >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…