Skip to content

← Actionable
High, CVSS 8.4amended

@hulumi/policies bypasses policy packs with a forged Pulumi-URN logical name

CVE-2026-48033GHSA-rhgj-6g2c-frmm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hulumi/policies 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2026-48033: 0.48% estimated exploitation activity in the next 30 days; percentile 41.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected: @hulumi/policies < 1.4.0 — Fixed in: 1.4.0 — Severity: High — CWE-693 (Protection Mechanism Failure) Summary Pulumi gives every cloud resource a structured URN that includes the resource's type chain (hulumi:baseline:aws:SecureBucket$aws:s3/bucketV2:BucketV2) and the logical name the developer freely chose (anything after the final ::). Several Hulumi policy rules used the URN to grant exemptions — for example, "if this raw bucket is a child of SecureBucket, skip the raw-bucket rule because the parent component handles hardening." The bug: the rules looked for a substring like hulumi:baseline:aws:SecureBucket$ anywhere in the URN. That substring can also appear in the developer-controlled logical-name portion. A developer (or compromised PR) could simply name a raw resource so its logical name carried the trusted substring, and every rule that used this check would treat the resource as if it were inside the trusted parent and skip its hardening check. Codex reported this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rhgj-6g2c-frmm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-rhgj-6g2c-frmm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48033

Advisory: @hulumi/policies bypasses policy packs with a forged Pulumi-URN logical name
IDs: CVE-2026-48033, GHSA-rhgj-6g2c-frmm
Record: https://patchnext.com/advisories/cve-2026-48033 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hulumi/policies 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hulumi/policies: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `npm ls @hulumi/policies --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hulumi/policies.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rhgj-6g2c-frmm (OSV record GHSA-rhgj-6g2c-frmm lists affected ranges: npm @hulumi/policies >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rhgj-6g2c-frmm (GitHub-reviewed advisory GHSA-rhgj-6g2c-frmm lists affected ranges: npm @hulumi/policies >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…