Skip to content

← Actionable
High, CVSS 8.3amended

@hulumi/policies bypasses IAM-role policy checks when the role trusts multiple OIDC providers

CVE-2026-48032GHSA-g759-4pxw-6692

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hulumi/policies 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-48032: 0.54% estimated exploitation activity in the next 30 days; percentile 45.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected: @hulumi/policies < 1.4.0 — Fixed in: 1.4.0 — Severity: High — CWE-697 (Incorrect Comparison) Summary AWS IAM trust policies can list more than one federated identity provider — for example, a role that accepts BOTH GitHub Actions OIDC and Google's OIDC. The GOIDC1 and GOIDC2 policy rules are supposed to flag IAM roles whose GitHub-OIDC trust is too permissive (e.g. wildcard sub: conditions that would let any branch or any pull request assume the role). The bug: when the role's Principal.Federated field was a JSON array of multiple providers, the rules failed to recognise that GitHub Actions was one of them. The providers list was coerced into a single comma-joined string, the matcher only looked at the start, and the GitHub OIDC hostname was lost in the join. Both rules concluded "this isn't a GitHub-OIDC role" and skipped the wildcard check. Impact A trust policy that listed the real GitHub OIDC provider ARN alongside any second provider would slip past both detectors.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g759-4pxw-6692

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-g759-4pxw-6692

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48032

Advisory: @hulumi/policies bypasses IAM-role policy checks when the role trusts multiple OIDC providers
IDs: CVE-2026-48032, GHSA-g759-4pxw-6692
Record: https://patchnext.com/advisories/cve-2026-48032 (revision 3, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hulumi/policies 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hulumi/policies: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- `npm ls @hulumi/policies --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hulumi/policies.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g759-4pxw-6692 (OSV record GHSA-g759-4pxw-6692 lists affected ranges: npm @hulumi/policies >=0 <1.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g759-4pxw-6692 (GitHub-reviewed advisory GHSA-g759-4pxw-6692 lists affected ranges: npm @hulumi/policies >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…