Pheditor: OS Command Injection in terminal handler via unsanitized 'dir' parameter
CVE-2026-48030GHSA-jvc5-6g7q-c843
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pheditor/pheditor 2.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pheditor/pheditor
- Affected
- >= 2.0.1, <= 2.0.3
- Fixed in
- 2.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jvc5-6g7q-c843 lists affected ranges: Packagist pheditor/pheditor >=2.0.1 <=2.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-48030: 7.55% estimated exploitation activity in the next 30 days; percentile 94.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An OS Command Injection vulnerability in the terminal action handler allows any authenticated user to execute arbitrary OS commands by injecting shell metacharacters into the 'dir' POST parameter, completely bypassing the TERMINALCOMMANDS whitelist and achieving full Remote Code Execution with web server privileges. Details The terminal handler in pheditor.php accepts two POST parameters: command and dir. Shell metacharacters are validated on $command only — $dir is passed to shellexec() without any sanitization. Vulnerable code (pheditor.php, line 554–586): An attacker sends dir=/tmp; curl attacker.com
— the semicolon in $dir is never checked, so the injected command executes freely. Fix: replace $dir with escapeshellarg($dir) on line 586. PoC Requirements: valid credentials, terminal permission enabled (default) Step 1 — Authenticate: Step 2 — Get CSRF token: Step 3 — Confirm curl is blocked via command field: Step 4 — Bypass whitelist via dir injection: Step 5 — Full RCE…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jvc5-6g7q-c843
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48030 Advisory: Pheditor: OS Command Injection in terminal handler via unsanitized 'dir' parameter IDs: CVE-2026-48030, GHSA-jvc5-6g7q-c843 Record: https://patchnext.com/advisories/cve-2026-48030 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pheditor/pheditor 2.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pheditor/pheditor: affected >= 2.0.1, <= 2.0.3; fixed in 2.0.4 ## Suggested inspection (read-only) - Packagist pheditor/pheditor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pheditor/pheditor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jvc5-6g7q-c843 (GitHub-reviewed advisory GHSA-jvc5-6g7q-c843 lists affected ranges: Packagist pheditor/pheditor >=2.0.1 <=2.0.3) Commands are suggestions: review each one before running it.
Loading voting…