Skip to content

← Actionable
Medium, CVSS 6.5amended

@hapi/wreck: Sensitive credential headers leak across cross-port and cross-scheme redirects

CVE-2026-48022GHSA-x426-x7cc-3fpc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hapi/wreck 18.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-48022: 0.18% estimated exploitation activity in the next 30 days; percentile 7.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Wreck strips credential headers (Authorization, Cookie, Proxy-Authorization) before following a cross-origin redirect, but the origin check compares hostnames only and ignores scheme and port. As a result, credentials are forwarded intact across same-host port changes and HTTPS-to-HTTP downgrades, allowing a co-tenant on an adjacent port or a network-position attacker capable of forging a redirect to capture bearer tokens, session cookies, and proxy credentials and impersonate the victim against the upstream service. The fix replaces the hostname comparison with a full-origin comparison (scheme, host, and port), aligning the behavior with the WHATWG Fetch same-origin definition used by browsers. Patches Upgrade to = 18.1.2. Workarounds - Set redirects: 0 (default) and handle redirects manually with a strict origin check. - Use the beforeRedirect hook to inspect the redirect target and abort or strip sensitive headers before the follow-on request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x426-x7cc-3fpc

  2. Revision 1 · created ·

    Published from osv record GHSA-x426-x7cc-3fpc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48022

Advisory: @hapi/wreck: Sensitive credential headers leak across cross-port and cross-scheme redirects
IDs: CVE-2026-48022, GHSA-x426-x7cc-3fpc
Record: https://patchnext.com/advisories/cve-2026-48022 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hapi/wreck 18.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hapi/wreck: affected < 18.1.2; fixed in 18.1.2

## Suggested inspection (read-only)
- `npm ls @hapi/wreck --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hapi/wreck.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x426-x7cc-3fpc (OSV record GHSA-x426-x7cc-3fpc lists affected ranges: npm @hapi/wreck >=0 <18.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-x426-x7cc-3fpc (GitHub-reviewed advisory GHSA-x426-x7cc-3fpc lists affected ranges: npm @hapi/wreck >=0 <18.1.2)

Commands are suggestions: review each one before running it.

Loading voting…