Skip to content

← Actionable
Medium, CVSS 4.3

Shopware: Unauthorized Payment Trigger for Foreign Orders via /store-api/handle-payment

CVE-2026-48016GHSA-9v5m-39wh-5chq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.10.1, 6.6.10.18; shopware/platform 6.7.10.1, 6.6.10.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist shopware/core

    Affected
    >= 6.7.0.0, < 6.7.10.1< 6.6.10.18
    Fixed in
    6.7.10.1, 6.6.10.18
  • Packagist shopware/platform

    Affected
    >= 6.7.0.0, < 6.7.10.1< 6.6.10.18
    Fixed in
    6.7.10.1, 6.6.10.18

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-48016: 0.41% estimated exploitation activity in the next 30 days; percentile 35.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Shopware Store API endpoint /store-api/handle-payment contains an object-level authorization flaw that allows a low-privileged external user with a normal customer or guest context to trigger the payment flow for another user’s order by supplying a foreign orderId. The affected functionality is the Store API payment initiation and retry flow. The root cause is that the endpoint forwards the user-controlled orderId into the payment processing logic without verifying that the caller owns the referenced order or has passed the required guest-order authentication. As a result, payment attempts for foreign orders are accepted by the server, which can compromise the integrity of order and payment workflows. Description Shopware exposes /store-api/handle-payment to initiate or retry the payment flow for an already created order. Under the normal order access model, customers should only be able to view or act on their own orders, and guest users should only be able to access…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9v5m-39wh-5chq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48016

Advisory: Shopware: Unauthorized Payment Trigger for Foreign Orders via /store-api/handle-payment
IDs: CVE-2026-48016, GHSA-9v5m-39wh-5chq
Record: https://patchnext.com/advisories/cve-2026-48016 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.10.1, 6.6.10.18; shopware/platform 6.7.10.1, 6.6.10.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopware/core: affected >= 6.7.0.0, < 6.7.10.1; < 6.6.10.18; fixed in 6.7.10.1, 6.6.10.18
- Packagist shopware/platform: affected >= 6.7.0.0, < 6.7.10.1; < 6.6.10.18; fixed in 6.7.10.1, 6.6.10.18

## Suggested inspection (read-only)
- Packagist shopware/core: check the installed version with your package manager.
- Packagist shopware/platform: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopware/core, shopware/platform.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9v5m-39wh-5chq (GitHub-reviewed advisory GHSA-9v5m-39wh-5chq lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.18)

Commands are suggestions: review each one before running it.

Loading voting…