Skip to content

← Actionable
Medium, CVSS 4.1

Shopware: SSRF in Media External-Link Endpoint Bypasses IP Validation

CVE-2026-48013GHSA-gq96-5pfx-f4vc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.10.1; shopware/platform 6.7.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-48013: 0.37% estimated exploitation activity in the next 30 days; percentile 30.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The /api/action/media/external-link endpoint allows authenticated admin users to make server-side HTTP HEAD requests to arbitrary internal IP addresses. While the parallel uploadFromURL flow validates target IPs against private/reserved ranges via FileUrlValidator, the linkURL flow only performs a URL format check (regex for http:// or https:// prefix), allowing SSRF to internal network services and cloud metadata endpoints. Details The vulnerability is an inconsistency between two URL-handling flows in MediaUploadService. Vulnerable path (external-link): MediaUploadV2Controller::externalLink() at src/Core/Content/Media/Api/MediaUploadV2Controller.php:66 takes a user-supplied url parameter and passes it to MediaUploadService::linkURL() at src/Core/Content/Media/Upload/MediaUploadService.php:134. linkURL() calls getContentSizeFromValidExternalUrl($url) at line 159, which only validates via validateExternalUrl(): Then makes a server-side HEAD request with no IP filtering:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gq96-5pfx-f4vc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48013

Advisory: Shopware: SSRF in Media External-Link Endpoint Bypasses IP Validation
IDs: CVE-2026-48013, GHSA-gq96-5pfx-f4vc
Record: https://patchnext.com/advisories/cve-2026-48013 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.10.1; shopware/platform 6.7.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopware/core: affected >= 6.7.0.0, < 6.7.10.1; fixed in 6.7.10.1
- Packagist shopware/platform: affected >= 6.7.0.0, < 6.7.10.1; fixed in 6.7.10.1

## Suggested inspection (read-only)
- Packagist shopware/core: check the installed version with your package manager.
- Packagist shopware/platform: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopware/core, shopware/platform.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gq96-5pfx-f4vc (GitHub-reviewed advisory GHSA-gq96-5pfx-f4vc lists affected ranges: Packagist shopware/core >=6.7.0.0 =6.7.0.0 <6.7.10.1)

Commands are suggestions: review each one before running it.

Loading voting…