Shopware: Privilege escalation: non-admin user with user:create ACL can create admin accounts
CVE-2026-48010GHSA-v39m-97p8-gqg7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.10.1, 6.6.10.18; shopware/platform 6.7.10.1, 6.6.10.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- >= 6.7.0.0, < 6.7.10.1< 6.6.10.18
- Fixed in
- 6.7.10.1, 6.6.10.18
Packagist shopware/platform
- Affected
- >= 6.7.0.0, < 6.7.10.1< 6.6.10.18
- Fixed in
- 6.7.10.1, 6.6.10.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v39m-97p8-gqg7 lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-48010: 0.47% estimated exploitation activity in the next 30 days; percentile 40.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
UserController::upsertUser() writes user data in SYSTEMSCOPE and does not filter the admin field. A non-admin API user with user:create or user:update ACL permission can set admin: true on new or existing users, escalating to full admin access. The Problem In src/Core/Framework/Api/Controller/UserController.php, line 210-234: SYSTEMSCOPE bypasses AclWriteValidator entirely (line 52 of AclWriteValidator::preValidate() returns early for SYSTEMSCOPE). The admin boolean field is accepted without restriction. Compare with IntegrationController::upsertIntegration() in the same codebase, which correctly checks: UserController is missing this exact check. Impact Any API user with the low-privilege user:create permission can create accounts with full admin access, or with user:update can promote any existing user to admin. This is a direct privilege escalation. Suggested Fix Add the same isAdmin() check from IntegrationController: Best regards, Keyvan Hardani
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v39m-97p8-gqg7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-48010 Advisory: Shopware: Privilege escalation: non-admin user with user:create ACL can create admin accounts IDs: CVE-2026-48010, GHSA-v39m-97p8-gqg7 Record: https://patchnext.com/advisories/cve-2026-48010 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.10.1, 6.6.10.18; shopware/platform 6.7.10.1, 6.6.10.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected >= 6.7.0.0, < 6.7.10.1; < 6.6.10.18; fixed in 6.7.10.1, 6.6.10.18 - Packagist shopware/platform: affected >= 6.7.0.0, < 6.7.10.1; < 6.6.10.18; fixed in 6.7.10.1, 6.6.10.18 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v39m-97p8-gqg7 (GitHub-reviewed advisory GHSA-v39m-97p8-gqg7 lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.18) Commands are suggestions: review each one before running it.
Loading voting…