Skip to content

← Actionable
Medium, CVSS 6.5

Shopware: Privilege Escalation via Sync API Integration Admin Flag Bypass

CVE-2026-48008GHSA-gv8p-48fr-4fxg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.10.1, 6.6.10.18; shopware/platform 6.7.10.1, 6.6.10.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist shopware/core

    Affected
    >= 6.7.0.0, < 6.7.10.1< 6.6.10.18
    Fixed in
    6.7.10.1, 6.6.10.18
  • Packagist shopware/platform

    Affected
    >= 6.7.0.0, < 6.7.10.1< 6.6.10.18
    Fixed in
    6.7.10.1, 6.6.10.18

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-48008: 0.47% estimated exploitation activity in the next 30 days; percentile 40.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A non-admin API user with integration:create ACL privilege can escalate to full administrator by creating an integration with admin: true through the Sync API (POST /api/action/sync). The regular integration endpoint (POST /api/integration) correctly blocks this, but the Sync API bypasses the controller-level check by writing directly through the DAL EntityWriter. The integration entity definition lacks WriteProtection, and the admin field has no field-level restriction flag. OWASP: A01:2021 — Broken Access Control Root Cause IntegrationController::upsertIntegration() checks $source-isAdmin() before allowing the admin field to be set. However, SyncController::sync() routes writes through SyncService → EntityWriter, which only applies: 1. AclWriteValidator — checks entity-level ACL (integration:create is sufficient) 2. EntityProtectionValidator — checks WriteProtection on entity definitions, but IntegrationDefinition has none The admin field in IntegrationDefinition is a plain…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gv8p-48fr-4fxg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-48008

Advisory: Shopware: Privilege Escalation via Sync API Integration Admin Flag Bypass
IDs: CVE-2026-48008, GHSA-gv8p-48fr-4fxg
Record: https://patchnext.com/advisories/cve-2026-48008 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.10.1, 6.6.10.18; shopware/platform 6.7.10.1, 6.6.10.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopware/core: affected >= 6.7.0.0, < 6.7.10.1; < 6.6.10.18; fixed in 6.7.10.1, 6.6.10.18
- Packagist shopware/platform: affected >= 6.7.0.0, < 6.7.10.1; < 6.6.10.18; fixed in 6.7.10.1, 6.6.10.18

## Suggested inspection (read-only)
- Packagist shopware/core: check the installed version with your package manager.
- Packagist shopware/platform: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopware/core, shopware/platform.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gv8p-48fr-4fxg (GitHub-reviewed advisory GHSA-gv8p-48fr-4fxg lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.18)

Commands are suggestions: review each one before running it.

Loading voting…