PDM: Project-Controlled .pdm-plugins Content Executes Before CLI Parsing
CVE-2026-47781GHSA-qq6c-99pv-prvf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pdm 2.27.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pdm
- Affected
- <= 2.26.9
- Fixed in
- 2.27.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qq6c-99pv-prvf lists affected ranges: PyPI pdm >=0 <2.27.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qq6c-99pv-prvf lists affected ranges: PyPI pdm >=0 <=2.26.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-47781: 0.19% estimated exploitation activity in the next 30 days; percentile 8.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary PDM automatically loads project-local plugin paths from .pdm-plugins during Core initialization. Because this path is added via site.addsitedir(), attacker-controlled .pth files inside the project plugin directory are processed and can execute Python code before normal CLI handling begins. This allows arbitrary code execution with the privileges of the user running pdm from an untrusted repository checkout. Affected Behavior - Trigger does not require pdm install --plugins - A low-impact command such as pdm --version is sufficient - Impact is strongest in CI, privileged shells, and automation contexts Affected Code - src/pdm/core.py:74-82 - src/pdm/core.py:310-333 - src/pdm/core.py:335-352 Technical Details Core.init() calls loadplugins() before ordinary command execution. loadplugins() calls addprojectpluginslibrary(), which derives the project-local .pdm-plugins library path and adds it through site.addsitedir(). On CPython, site.addsitedir() processes .pth files found in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qq6c-99pv-prvf
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qq6c-99pv-prvf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47781 Advisory: PDM: Project-Controlled `.pdm-plugins` Content Executes Before CLI Parsing IDs: CVE-2026-47781, GHSA-qq6c-99pv-prvf Record: https://patchnext.com/advisories/cve-2026-47781 (revision 3, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pdm 2.27.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pdm: affected <= 2.26.9; fixed in 2.27.0 ## Suggested inspection (read-only) - `python -m pip show pdm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pdm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qq6c-99pv-prvf (OSV record GHSA-qq6c-99pv-prvf lists affected ranges: PyPI pdm >=0 <2.27.0 (fixed)) - Verified: https://github.com/advisories/GHSA-qq6c-99pv-prvf (GitHub-reviewed advisory GHSA-qq6c-99pv-prvf lists affected ranges: PyPI pdm >=0 <=2.26.9) Commands are suggestions: review each one before running it.
Loading voting…