Skip to content

← Actionable
Medium, CVSS 6.8amended

PDM: Project-Local State and Config Writes Follow Symlinks

CVE-2026-47763GHSA-ghq2-5c67-fprm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pdm 2.27.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pdm

    Affected
    < 2.27.0
    Fixed in
    2.27.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-47763: 0.20% estimated exploitation activity in the next 30 days; percentile 9.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary PDM writes several project-local state or configuration files without symlink protection. If a malicious repository places those files as symlinks, local PDM operations can overwrite the symlink targets. This creates an arbitrary file clobber primitive relative to the privileges of the invoking user. Affected Behavior - Project-local config writes can affect files outside the repository - The most stable demonstrated sink is pdm.toml - Related sinks include .pdm-python and .python-version Affected Code - src/pdm/project/config.py:303-350 - src/pdm/project/core.py:209-217 - src/pdm/cli/commands/use.py:187-189 Technical Details Config.init() resolves the project-local pdm.toml path and saveconfig() writes to the resolved target. If PROJECTROOT/pdm.toml is a symlink to another file, pdm config -l ... updates the target file instead of refusing the write. The same general problem exists for other project-local persistence paths that are written directly with no lstat / ONOFOLLOW…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-ghq2-5c67-fprm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-ghq2-5c67-fprm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47763

Advisory: PDM: Project-Local State and Config Writes Follow Symlinks
IDs: CVE-2026-47763, GHSA-ghq2-5c67-fprm
Record: https://patchnext.com/advisories/cve-2026-47763 (revision 3, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pdm 2.27.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pdm: affected < 2.27.0; fixed in 2.27.0

## Suggested inspection (read-only)
- `python -m pip show pdm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pdm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ghq2-5c67-fprm (OSV record GHSA-ghq2-5c67-fprm lists affected ranges: PyPI pdm >=0 <2.27.0 (fixed))
- Verified: https://github.com/advisories/GHSA-ghq2-5c67-fprm (GitHub-reviewed advisory GHSA-ghq2-5c67-fprm lists affected ranges: PyPI pdm >=0 <2.27.0)

Commands are suggestions: review each one before running it.

Loading voting…