Skip to content

← Actionable
High, CVSS 8.7amended

TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs

CVE-2026-47760GHSA-mh5m-5hw4-5c69

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 7.1.0; tinymce/tinymce 7.1.0; tinymce 7.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet tinymce

    Affected
    >= 6.8.0, < 7.1.0
    Fixed in
    7.1.0
  • Packagist tinymce/tinymce

    Affected
    >= 6.8.0, < 7.1.0
    Fixed in
    7.1.0
  • npm tinymce

    Affected
    >= 6.8.0, < 7.1.0
    Fixed in
    7.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-47760: 0.19% estimated exploitation activity in the next 30 days; percentile 8.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact TinyMCE 6.8.x contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested <svg elements can bypass attribute sanitization and execute arbitrary JavaScript. Patches This issue affects TinyMCE 6.8.x-7.0.x. The vulnerability is fixed in TinyMCE 7.1.0 and later. Workarounds No official workaround available. Acknowledgements Tiny thanks maple3142 (<https://maple3142.net) of DEVCORE for their help identifying this vulnerability. References Fix introduced in TinyMCE 7.1.0 though a rewrite of code causing the vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mh5m-5hw4-5c69

  2. Revision 1 · created ·

    Published from osv record GHSA-mh5m-5hw4-5c69

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-47760

Advisory: TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs
IDs: CVE-2026-47760, GHSA-mh5m-5hw4-5c69
Record: https://patchnext.com/advisories/cve-2026-47760 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tinymce 7.1.0; tinymce/tinymce 7.1.0; tinymce 7.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet tinymce: affected >= 6.8.0, < 7.1.0; fixed in 7.1.0
- Packagist tinymce/tinymce: affected >= 6.8.0, < 7.1.0; fixed in 7.1.0
- npm tinymce: affected >= 6.8.0, < 7.1.0; fixed in 7.1.0

## Suggested inspection (read-only)
- NuGet tinymce: check the installed version with your package manager.
- Packagist tinymce/tinymce: check the installed version with your package manager.
- `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tinymce, tinymce/tinymce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mh5m-5hw4-5c69 (OSV record GHSA-mh5m-5hw4-5c69 lists affected ranges: npm tinymce >=6.8.0 =6.8.0 =6.8.0 <7.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mh5m-5hw4-5c69 (GitHub-reviewed advisory GHSA-mh5m-5hw4-5c69 lists affected ranges: npm tinymce >=6.8.0 =6.8.0 =6.8.0 <7.1.0)

Commands are suggestions: review each one before running it.

Loading voting…