TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes
CVE-2026-47759GHSA-q742-qvgc-gc2f
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet tinymce
- Affected
- >= 6.0.0, < 7.9.3>= 8.0.0, < 8.5.1<= 5.10.9
- Fixed in
- 7.9.3, 8.5.1
Packagist tinymce/tinymce
- Affected
- >= 6.0.0, < 7.9.3>= 8.0.0, < 8.5.1<= 5.10.9
- Fixed in
- 7.9.3, 8.5.1
npm tinymce
- Affected
- >= 6.0.0, < 7.9.3>= 8.0.0, < 8.5.1<= 5.10.9
- Fixed in
- 7.9.3, 8.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q742-qvgc-gc2f lists affected ranges: npm tinymce >=0 =6.0.0 =8.0.0 =0 =6.0.0 =8.0.0 =0 =6.0.0 =8.0.0 <8.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q742-qvgc-gc2f lists affected ranges: npm tinymce >=6.0.0 =8.0.0 =0 =6.0.0 =8.0.0 =0 =6.0.0 =8.0.0 =0 <=5.10.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2026-47759: 0.28% estimated exploitation activity in the next 30 days; percentile 20.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Stored XSS vulnerability via unsanitized data-mce- attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. Patches Patched by stripping unsafe data-mce- attributes during parsing. Users should upgrade to the latest patched versions (5 LTS, 7.x, 8.x). Workarounds No official workaround available. Fix To avoid this vulnerability: Upgrade to TinyMCE 8.5.1 or higher. Upgrade to TinyMCE 7.9.3 or higher. Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract). Acknowledgements Tiny thanks Tadi Kadango (website) and Ivan Babenko for their help identifying this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q742-qvgc-gc2f
- Revision 1 · created ·
Published from osv record GHSA-q742-qvgc-gc2f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-47759 Advisory: TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes IDs: CVE-2026-47759, GHSA-q742-qvgc-gc2f Record: https://patchnext.com/advisories/cve-2026-47759 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: tinymce 8.5.1, 7.9.3; tinymce/tinymce 8.5.1, 7.9.3; tinymce 8.5.1, 7.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet tinymce: affected >= 6.0.0, < 7.9.3; >= 8.0.0, < 8.5.1; <= 5.10.9; fixed in 7.9.3, 8.5.1 - Packagist tinymce/tinymce: affected >= 6.0.0, < 7.9.3; >= 8.0.0, < 8.5.1; <= 5.10.9; fixed in 7.9.3, 8.5.1 - npm tinymce: affected >= 6.0.0, < 7.9.3; >= 8.0.0, < 8.5.1; <= 5.10.9; fixed in 7.9.3, 8.5.1 ## Suggested inspection (read-only) - NuGet tinymce: check the installed version with your package manager. - Packagist tinymce/tinymce: check the installed version with your package manager. - `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tinymce, tinymce/tinymce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q742-qvgc-gc2f (OSV record GHSA-q742-qvgc-gc2f lists affected ranges: npm tinymce >=0 =6.0.0 =8.0.0 =0 =6.0.0 =8.0.0 =0 =6.0.0 =8.0.0 <8.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-q742-qvgc-gc2f (GitHub-reviewed advisory GHSA-q742-qvgc-gc2f lists affected ranges: npm tinymce >=6.0.0 =8.0.0 =0 =6.0.0 =8.0.0 =0 =6.0.0 =8.0.0 =0 <=5.10.9) Commands are suggestions: review each one before running it.
Loading voting…